Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.20.3
    • Fix Version/s: 0.21.1
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      As the first short-term step let's remove JDK5 dependency from build(s)

      1. HADOOP-7072.patch
        12 kB
        Konstantin Boudnik
      2. HADOOP-7072.0.20.patch
        12 kB
        Konstantin Boudnik
      3. HADOOP-7072.0.20.patch
        12 kB
        Konstantin Boudnik

        Issue Links

          Activity

          hudson Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #643 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk/643/)

          szetszwo Tsz Wo Nicholas Sze added a comment -

          test-patch.sh has a problem. See HADOOP-7120.

          hudson Hudson added a comment -

          Integrated in Hadoop-Common-trunk #567 (See https://hudson.apache.org/hudson/job/Hadoop-Common-trunk/567/)

          hudson Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #568 (See https://hudson.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/568/)
          HADOOP-7072. Fixing incorrect count of parameters.

          cos Konstantin Boudnik added a comment -

          The fix has been reviewed by Nigel (RM for 0.22) as it is (e.g. with 0.20.3 as an oldest affected branch). I am not going to commit to 0.20 though because I am not sure if we are going to make any more 0.20 release - thus this fix doesn't seem important enough to be included there. However, I have added the patch if someone needs it.

          jghoman Jakob Homan added a comment -

          should this have gone to 20 and 21? It's listed as an improvement, not a bug fix, which I think is a correct description. Also, does Nigel want this in 22? As RM, he should be pulling things in or asking explicitly for them to be included in the branch.

          cos Konstantin Boudnik added a comment -

          Fixing incorrect count of parameters.

          cos Konstantin Boudnik added a comment -

          I have committed this to the trunk and 0.21, 0.22 branches

          cos Konstantin Boudnik added a comment -

          the same for 0.20

          cos Konstantin Boudnik added a comment -

          Thanks for the review, Nige.

          Let's do top-level site as a separate JIRA. I'll open one and link it here.

          nidaley Nigel Daley added a comment -

          +1. Looks good. Will need to do this for the top level site too (http://svn.apache.org/repos/asf/hadoop/site/build.xml)

          cos Konstantin Boudnik added a comment -

          Anyone cares to review?

          hadoopqa Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12466785/HADOOP-7072.patch
          against trunk revision 1051659.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 4 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          +1 system test framework. The patch passed system test framework compile.

          Test results: https://hudson.apache.org/hudson/job/PreCommit-HADOOP-Build/145//testReport/
          Findbugs warnings: https://hudson.apache.org/hudson/job/PreCommit-HADOOP-Build/145//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: https://hudson.apache.org/hudson/job/PreCommit-HADOOP-Build/145//console

          This message is automatically generated.

          cos Konstantin Boudnik added a comment -

          Thanks, Nigel: I am aware about the externals. I will do the rest of the projects tomorrow: was a long day already.

          nidaley Nigel Daley added a comment -

          Thx Cos. FWIW the precommit testing doesn't work so well when the patch changes the test-patch.sh

          Note that changing the params to test-patch.sh will require a synchronized update across all 3 project build files since this script is shared (via svn externals) across projects. I'll review the patch tomorrow.

          cos Konstantin Boudnik added a comment -

          Checking

          cos Konstantin Boudnik added a comment -

          Trunk fix. and docs now works without -Djava5.home


            People

            • Assignee:
              cos Konstantin Boudnik
              Reporter:
              cos Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development