Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.8.1.2
    • Fix Version/s: 10.8.1.2
    • Component/s: SQL
    • Labels:
      None
    • Issue & fix info:
      Release Note Needed

      Description

      Enable automatic updates and creations of index cardinality statistics, and wire the tests into the regression suite.

      1. derby-4939-1a-enable_istat.diff
        3 kB
        Kristian Waagan
      2. releaseNote.html
        5 kB
        Rick Hillegas
      3. releaseNote.html
        5 kB
        Rick Hillegas
      4. releaseNote.html
        5 kB
        Knut Anders Hatlen
      5. releaseNote.html
        5 kB
        Knut Anders Hatlen

        Issue Links

          Activity

          Kristian Waagan created issue -
          Kristian Waagan made changes -
          Field Original Value New Value
          Assignee Kristian Waagan [ kristwaa ]
          Kristian Waagan made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Kristian Waagan added a comment -

          Attached patch 1a, which enables the feature.

          I expect there will be issues to deal with, please bring them up on derby-dev and/or file JIRA issues.

          To disable the feature use derby.storage.indexStats.auto=false.
          See https://issues.apache.org/jira/browse/DERBY-4938?focusedCommentId=12992769&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-12992769 (or DERBY-4771) for more information on the available experimental (debug/troubleshooting) knobs.

          Committed to trunk with revision 1069598.

          Kristian Waagan made changes -
          Attachment derby-4939-1a-enable_istat.diff [ 12470808 ]
          Mike Matrigali made changes -
          Link This issue breaks DERBY-5038 [ DERBY-5038 ]
          Mike Matrigali made changes -
          Link This issue breaks DERBY-5039 [ DERBY-5039 ]
          Knut Anders Hatlen made changes -
          Link This issue breaks DERBY-5045 [ DERBY-5045 ]
          Kristian Waagan added a comment -

          Closing issue.
          The feature has been enabled, and the first batch of errors has been partially addressed.
          I consider the situation as good enough such that there is no need to disable the feature at this point.

          Kristian Waagan made changes -
          Status In Progress [ 3 ] Closed [ 6 ]
          Fix Version/s 10.8.0.0 [ 12315561 ]
          Resolution Fixed [ 1 ]
          Knut Anders Hatlen added a comment -

          Reopening to allow attaching a release note.

          Knut Anders Hatlen made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Knut Anders Hatlen made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Issue & fix info [Release Note Needed]
          Resolution Fixed [ 1 ]
          Knut Anders Hatlen added a comment -

          Uploading a first attempt on a release note. Feel free to improve as needed.

          Knut Anders Hatlen made changes -
          Attachment releaseNote.html [ 12472423 ]
          Knut Anders Hatlen made changes -
          Link This issue is related to DERBY-5086 [ DERBY-5086 ]
          Rick Hillegas added a comment -

          Thanks for the release note, Knut. It looks good. It may need to be adjusted if you go ahead and disable the logging of statistics update events. Thanks.

          Knut Anders Hatlen added a comment -

          Updated the release note to reflect that logging is now disabled by default.

          Knut Anders Hatlen made changes -
          Attachment releaseNote.html [ 12472517 ]
          Kristian Waagan made changes -
          Link This issue incorporates DERBY-5026 [ DERBY-5026 ]
          Kristian Waagan made changes -
          Link This issue incorporates DERBY-5030 [ DERBY-5030 ]
          Kristian Waagan made changes -
          Link This issue incorporates DERBY-5037 [ DERBY-5037 ]
          Kristian Waagan made changes -
          Link This issue incorporates DERBY-5040 [ DERBY-5040 ]
          Kristian Waagan made changes -
          Link This issue incorporates DERBY-5046 [ DERBY-5046 ]
          Kristian Waagan made changes -
          Link This issue incorporates DERBY-5057 [ DERBY-5057 ]
          Kristian Waagan made changes -
          Link This issue incorporates DERBY-5082 [ DERBY-5082 ]
          Kristian Waagan made changes -
          Link This issue incorporates DERBY-5087 [ DERBY-5087 ]
          Kristian Waagan made changes -
          Link This issue incorporates DERBY-5088 [ DERBY-5088 ]
          Kristian Waagan made changes -
          Link This issue incorporates DERBY-5031 [ DERBY-5031 ]
          Kristian Waagan made changes -
          Link This issue is related to DERBY-5067 [ DERBY-5067 ]
          Kristian Waagan made changes -
          Link This issue is related to DERBY-5083 [ DERBY-5083 ]
          Kristian Waagan made changes -
          Link This issue is related to DERBY-4940 [ DERBY-4940 ]
          Kristian Waagan made changes -
          Link This issue is related to DERBY-5089 [ DERBY-5089 ]
          Kristian Waagan made changes -
          Link This issue is related to DERBY-4947 [ DERBY-4947 ]
          Kristian Waagan added a comment -

          I added a bunch of links, with the following groups:

          • incorporates : bugs in the feature itself or in the new tests
          • breaks : existing tests broken by the new feature
          • is related to : various follow-up work, or changes required due to side-effects caused by the new feature
          Rick Hillegas made changes -
          Link This issue is related to DERBY-5131 [ DERBY-5131 ]
          Rick Hillegas added a comment -

          Attaching a new version of the release note. This version describes the default 10.8.1 behavior: by default the istat daemon does not run automatically in 10.8.1.

          Rick Hillegas made changes -
          Attachment releaseNote.html [ 12473566 ]
          Rick Hillegas added a comment -

          Re-attaching the 2011-03-03 release note since we have re-enabled istat=on as the default behavior for 10.8.1.

          Rick Hillegas made changes -
          Attachment releaseNote.html [ 12474176 ]
          Andrew McIntyre added a comment -
          Show
          Andrew McIntyre added a comment -
          Dag H. Wanvik added a comment -

          Small comment on the release notes:

          > "During query compilation, Derby now checks if the index cardinality statistics for the tables involved in the query are out of date. If > the statistics are outdated, the query compiler will schedule a job that updates them in a separate thread. "

          Strictly speaking, "out-of-date" is an elusive goal, we can't really claim more than a best shot using heuristics. So maybe we should
          qualify this statement to say something like "deemed out of date", and add a sentence to say that one can always force an update using SYSCS_UTIL.SYSCS_UPDATE_STATISTICS if the automation doesn't work well enough for an application?

          Rick Hillegas added a comment -

          Hi Dag,

          Those sound like reasonable improvements to the detailed release note for this issue. Feel free to post an improved note. Thanks.

          Rick Hillegas made changes -
          Affects Version/s 10.8.1.1 [ 12316356 ]
          Affects Version/s 10.8.1.0 [ 12315561 ]
          Fix Version/s 10.8.1.1 [ 12316356 ]
          Fix Version/s 10.8.1.0 [ 12315561 ]
          Rick Hillegas made changes -
          Affects Version/s 10.8.1.2 [ 12316362 ]
          Affects Version/s 10.8.1.1 [ 12316356 ]
          Fix Version/s 10.8.1.2 [ 12316362 ]
          Fix Version/s 10.8.1.1 [ 12316356 ]
          Kristian Waagan added a comment -

          Closing issue, the feature has been enabled and most of the resulting problems have been resolved.
          I think we have JIRAs for the remaining bugs that surfaced when the feature was first enabled, none of which were considered show-stoppers for the release.

          Kristian Waagan made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Gavin made changes -
          Workflow jira [ 12539565 ] Default workflow, editable Closed status [ 12800936 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open In Progress In Progress
          65d 1h 29m 1 Kristian Waagan 10/Feb/11 22:44
          In Progress In Progress Closed Closed
          14d 22h 26m 1 Kristian Waagan 25/Feb/11 21:10
          Closed Closed Reopened Reopened
          4d 15h 40m 1 Knut Anders Hatlen 02/Mar/11 12:50
          Reopened Reopened Resolved Resolved
          23s 1 Knut Anders Hatlen 02/Mar/11 12:51
          Resolved Resolved Closed Closed
          84d 8h 59m 1 Kristian Waagan 25/May/11 22:50

            People

            • Assignee:
              Kristian Waagan
              Reporter:
              Kristian Waagan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development