Derby
  1. Derby
  2. DERBY-4934

Provide automatic update and creation of index cardinality statistics (istat)

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.8.1.2
    • Fix Version/s: 10.8.1.2
    • Component/s: SQL, Store
    • Labels:
      None
    • Bug behavior facts:
      Performance

      Description

      Derby has been having problems with stale index cardinality statistics causing performance degradation because the optimizer picks a sub-optimal plan.
      This master JIRA issue tracks the addition of a feature that will automatically update and create index cardinality statistics.

      Note: For brevity I have decided to call the the feature istat during development

        Issue Links

          Activity

          Kristian Waagan added a comment -

          The feature has been implemented and delivered as part of the 10.8 release.
          Closing issue.

          Kristian Waagan added a comment -

          The work on this feature is basically done for the 10.8 release, but there are still a few outstanding issues. I do plan to mark this issue as resolved before the RC is cut (please do so for me if I'm not around to do it ).
          I added a bunch of links to DERBY-4939, see that issue for an overview over initial issues caused by this new feature.


            People

            • Assignee:
              Kristian Waagan
              Reporter:
              Kristian Waagan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development