Derby
  1. Derby
  2. DERBY-5046

Intermittent assert failure in AutomaticIndexStatisticsTest.testStatisticsCorrectness

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.8.1.2
    • Fix Version/s: 10.8.1.2
    • Component/s: Test
    • Labels:
      None
    • Bug behavior facts:
      Regression Test Failure

      Description

      An assert on timestamps in the test AutomaticIndexStatisticsTest.testStatisticsCorrectnes is unstable, and fails on sufficiently fast machines and/or operating systems with lower resolution timers.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open In Progress In Progress
          3h 1m 1 Kristian Waagan 16/Feb/11 16:27
          In Progress In Progress Resolved Resolved
          1h 45m 1 Kristian Waagan 16/Feb/11 18:13
          Resolved Resolved Closed Closed
          98d 3h 25m 1 Kristian Waagan 25/May/11 22:38
          Gavin made changes -
          Workflow jira [ 12556225 ] Default workflow, editable Closed status [ 12802101 ]
          Gavin made changes -
          Link This issue relates to DERBY-6144 [ DERBY-6144 ]
          Gavin made changes -
          Link This issue relates to DERBY-6144 [ DERBY-6144 ]
          Mike Matrigali made changes -
          Link This issue relates DERBY-6144 [ DERBY-6144 ]
          Knut Anders Hatlen made changes -
          Link This issue is related to DERBY-5964 [ DERBY-5964 ]
          Kristian Waagan made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Kristian Waagan added a comment -

          Closing issue, I have seen no more reports of this error.

          Rick Hillegas made changes -
          Affects Version/s 10.8.1.2 [ 12316362 ]
          Affects Version/s 10.8.1.1 [ 12316356 ]
          Fix Version/s 10.8.1.2 [ 12316362 ]
          Fix Version/s 10.8.1.1 [ 12316356 ]
          Rick Hillegas made changes -
          Affects Version/s 10.8.1.1 [ 12316356 ]
          Affects Version/s 10.8.1.0 [ 12315561 ]
          Fix Version/s 10.8.1.1 [ 12316356 ]
          Fix Version/s 10.8.1.0 [ 12315561 ]
          Kristian Waagan made changes -
          Link This issue is part of DERBY-4939 [ DERBY-4939 ]
          Kristian Waagan made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Issue & fix info [Patch Available]
          Fix Version/s 10.8.0.0 [ 12315561 ]
          Resolution Fixed [ 1 ]
          Kristian Waagan added a comment -

          Thanks, Knut.
          Yes, the problem was identical timestamps. The existing assert demanded s.before(now) to be true.

          Committed to trunk with revision 1071348.

          Knut Anders Hatlen added a comment -

          So the problem was that the two timestamps were identical? The patch seems to fix that problem. +1 to commit.

          Kristian Waagan made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Kristian Waagan made changes -
          Issue & fix info [Patch Available]
          Kristian Waagan made changes -
          Field Original Value New Value
          Attachment derby-5046-1a-relax_assert.diff [ 12471171 ]
          Kristian Waagan added a comment -

          Attaching patch 1a, which relaxes the assert on the timestamps.

          Patch ready for review.

          Kristian Waagan added a comment -

          1) testStatisticsCorrectness(org.apache.derbyTesting.functionTests.tests.store.AutomaticIndexStatisticsTest)junit.framework.AssertionFailedError
          at org.apache.derbyTesting.functionTests.tests.store.AutomaticIndexStatisticsTest.testStatisticsCorrectness(AutomaticIndexStatisticsTest.java:346)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:112)
          at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
          at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
          at junit.extensions.TestSetup.run(TestSetup.java:25)
          at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
          at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
          at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
          at junit.extensions.TestSetup.run(TestSetup.java:25)

          Kristian Waagan created issue -

            People

            • Assignee:
              Kristian Waagan
              Reporter:
              Kristian Waagan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development