Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-1896

Reconfig error messages when upgrading from 3.4.6 to 3.5.0

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 3.5.0
    • Fix Version/s: 3.5.4, 3.6.0
    • Component/s: server
    • Labels:
      None

      Description

      When upgrading from 3.4.6 (rc0 actually) to 3.5.0 (trunk as of two weeks ago actually) I got this error message:

      2014-02-26 22:12:15,446 - ERROR [WorkerReceiver[myid=4]] - Something went wrong while processing config received from 3
      

      According to Flavio Junqueira:

      I think you’re right that the reconfig error is harmless, but we shouldn’t be getting it. The problem is that it is not detecting that we are in backward compatibility mode. We need to fix it for 3.5.0 and perhaps ZOOKEEPER-1805 is the right place for doing it.

      cc: Alexander Shraer

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                rgs Raul Gutierrez Segales
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: