Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.2.0
    • Fix Version/s: 0.8.2, 0.9.0
    • Component/s: new provider
    • Labels:
      None

      Description

      OpenStack is an emerging cloud management platform http://openstack.org/. We need an adaptor so that we can interface with OpenStack clouds for compute and storage resources. They had a release lthis week [10/25/10] and are having a summit next week. First we need to see how stabe the release is and also their roadmap.
      An adaptor - most probably at the JCloud level would be first try.

        Issue Links

          Activity

          Adrian Cole added a comment -

          hey there. do you have a public endpoint to test on? jclouds tried this earlier, when the stack was a bit newer. we should try again: http://code.google.com/p/jclouds/issues/detail?id=355

          Krishna Sankar added a comment -

          We meet again ! How are things ?

          I don't have one now, but can setup one. Let us wait after their summit.

          Cheers
          <k/>

          Adrian Cole added a comment -

          I'll be ready to help, albeit from europe. this is going to be very popular! catch me on freenode #whirr or #jclouds when you are ready, krishna

          Krishna Sankar added a comment -

          Saw the JCloud JIRA on OpenStack. We have technical contacts at OpenStack.
          Let me work on getting an end point.
          Cheers
          <k/>

          https://issues.apache.org/jira/browse/WHIRR-118?page=com.atlassian.jira.plugi>>
          n
          .system.issuetabpanels:comment-tabpanel&focusedCommentId=12925645#action_1292>>
          5

          Tom White added a comment -

          This would be good to have. Shouldn't this be on the jclouds issue tracker?

          Adrian Cole added a comment -

          Krishna. how's the endpoint coming along?

          Cheers,
          -Adrian

          Adrian Cole added a comment -

          you should be able to try this by changing the jclouds dependency to snapshot. openstack nova support will be a part of jclouds beta-10

          http://code.google.com/p/jclouds/wiki/QuickStartOpenStack

          Andrei Savu added a comment -

          Can we move on with this one now that jclouds 1.0.0 is out?

          Andrei Savu added a comment -

          See https://trystack.org/ for a test environment.

          Iman Yusuf added a comment -

          Hi,

          I use whirr to run cloud services on Amazon EC2. I am really excited to use whirr with Openstack as well. However, I could not find an example of using whirr with Openstack. In the whirr 7.1 package, there are examples for EC2 and Rackspace. There is one for byon as well. But I am not sure how to specify the properties of an Openstack cloud. A 5-minute working example for whirr with Openstack would be very helpful.

          Regards,
          Iman

          Andrei Savu added a comment -

          We need to upgrade to jclouds 1.5.0 in order to be able to make this happen. Your help with WHIRR-593 is highly appreciated.

          Adrian Cole added a comment -

          note we also need to detect and employ security groups, if the extension is present: http://docs.openstack.org/developer/nova/api_ext/ext_security_group.html

          org.jclouds.openstack.nova.v2_0.getSecurityGroupExtensionForZone
          org.jclouds.openstack.nova.v2_0.extensions.SecurityGroupApi

          Paul Baclace added a comment - - edited

          At this time, HPCloud has this:

          <extension name="SecurityGroups" namespace="http://docs.openstack.org/ext/securitygroups/api/v1.1" alias="security_groups" updated="2011-07-21T00:00:00+00:00"><description>Security group support</description></extension>

          where the 1.1 security groups docs are at:
          http://wiki.openstack.org/os-security-groups

          which means properties like these could almost work:

          # whirr.firewall-rules.

          {role}=
          whirr.firewall-rules.zookeeper=2181,2888,3888
          #any role#whirr.firewall-rules=80
          whirr.client-cidrs=10.4.1.2/32,10.4.3.3/32

          Looking at the src code, the whirr.client-cidrs are used to constrain the origins allowed to access the specified ports in whirr.firewall-rules.* props.

          Note the comma sep cidr addresses using /32 for exact match, but the problem is this property cannot be specified ahead of time. Perhaps allowing whirr.client-cidrs=role1,role2 would make sense by symmetry with whirr.firewall-rules.{role}

          . OR, an unset whirr.client-cidrs= could mean all the nodes just allocated and whirr.client-cidrs=0.0.0.0/0 can then be used to mean everywhere.

          Andrew Bayer added a comment -

          Security groups covered in WHIRR-711.


            People

            • Assignee:
              Andrew Bayer
              Reporter:
              Krishna Sankar
            • Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development