Pig
  1. Pig
  2. PIG-2972

Umbrella ticket for test failures in 0.11/trunk

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.11
    • Fix Version/s: 0.11
    • Component/s: None
    • Labels:
      None
    1.
    Test failures on CentOS 6 because MALLOC_ARENA_MAX is not set Sub-task Closed Cheolsoo Park
     
    2.
    TestPoissonSampleLoader failing on rhel environment Sub-task Closed Jonathan Coveney
     
    3.
    org.apache.pig.test.TestPigServerWithMacros fails sometimes because it picks up previous minicluster configuration file Sub-task Closed Cheolsoo Park
     
    4.
    TestIndexedStorage is failing, should be refactored Sub-task Closed Jonathan Coveney
     
    5.
    Fix e2e test failures in trunk: FilterBoolean_23/24 Sub-task Closed Cheolsoo Park
     
    6.
    Fix unit tests to work with jdk7 Sub-task Closed Rohini Palaniswamy
     
    7.
    TestStreaming test times out Sub-task Closed Cheolsoo Park
     
    8.
    StreamingLocal_11 e2e test hangs Sub-task Resolved Unassigned
     
    9.
    Fix Glob_local test failure for Pig E2E Test Framework Sub-task Closed Sushant Joshi
     
    10.
    TestTypedMap.testOrderBy failing with incorrect result Sub-task Closed Koji Noguchi
     
    11.
    TestHBaseStorage fails with hadoop-2.0.x Sub-task Resolved Unassigned
     
    12.
    TestLoadStoreFuncLifeCycle fails with hadoop-2.0.x Sub-task Closed Cheolsoo Park
     
    13.
    Pig.jar doesn't work with hadoop-2.0.x Sub-task Closed Cheolsoo Park
     
    14.
    MergeJoin, MergeSparseJoin, and Order e2e test fail Sub-task Resolved Unassigned
     
    15.
    TestRank1,2,3 fail with hadoop-2.0.x Sub-task Closed Rohini Palaniswamy
     
    16.
    TestCounters fails Sub-task Resolved Unassigned
     
    17.
    Fix local mode on Hadoop-0.23 Sub-task Resolved Unassigned
     
    18.
    Fix TestScriptLanguage and TestMacroExpansion Sub-task Closed Cheolsoo Park
     
    19.
    TestExecutableManager.testAddJobConfToEnv fails randomly Sub-task Closed Cheolsoo Park
     
    20.
    Regression after PIG-2975: BinInterSedesTupleRawComparator secondary sort failing Sub-task Closed Koji Noguchi
     
    21.
    TestRegisteredJarVisibility.testRegisteredJarVisibility fails with hadoop-2.0.x Sub-task Closed Rohini Palaniswamy
     
    22.
    TestPigContext.testImportList fails with hadoop-2.0.x Sub-task Resolved Rohini Palaniswamy
     

      Activity

      Rohini Palaniswamy added a comment -

      Test failures with existing jiras:
      General:

      Platform related failures:

      e2e Test Failures:

      Cheolsoo Park added a comment -

      Closing it since all sub-tasks are resolved or moved out of 0.11.


        People

        • Assignee:
          Unassigned
          Reporter:
          Rohini Palaniswamy
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development