Uploaded image for project: 'Pig'
  1. Pig
  2. PIG-2972 Umbrella ticket for test failures in 0.11/trunk
  3. PIG-3022

TestRegisteredJarVisibility.testRegisteredJarVisibility fails with hadoop-2.0.x

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.11
    • Fix Version/s: 0.11
    • Component/s: None
    • Labels:
      None
    • Environment:

      CentOS 6.2
      Java HotSpot(TM) 64-Bit 1.6.0_31

      Description

      To reproduce:

      ant clean test -Dtestcase=TestRegisteredJarVisibility -Dhadoopversion=23
      

      The test job always fails with YARN mini cluster:

      2012-10-31 17:34:02,277 WARN  [AsyncDispatcher event handler] resourcemanager.RMAuditLogger (RMAuditLogger.java:logFailure(255)) - USER=cheolsoo    OPERATION=Application Finished - Failed TARGET=RMAppManager RESULT=FAILURE  DESCRIPTION=App failed with state: FAILED   PERMISSIONS=Application application_1351730024514_0001 failed 1 times due to AM Container for appattempt_1351730024514_0001_000001 exited with  exitCode: 1 due to:
      .Failing this attempt.. Failing the application.    APPID=application_1351730024514_0001
      
      1. PIG-3022.patch
        0.7 kB
        Rohini Palaniswamy

        Issue Links

          Activity

          rohini Rohini Palaniswamy added a comment -

          For some reason $PWD/* is not getting expanded in the CLASSPATH(set in launcher_container.sh by YARN) and test-foo-loader.jar is not included in the classpath. Checked launcher_container.sh in a actual cluster job, and there seems to be nothing wrong or different with the one in the unit test even though part of it comes from mrapp-generated-classpath. Not sure why $PWD is not getting expanded in unit test env.

          rohini Rohini Palaniswamy added a comment -

          Found the issue. clover.jar is in path element and when it is not correctly substituted it causes CLASSPATH to not expand correctly.

          cheolsoo Cheolsoo Park added a comment -

          +1.

          Verified that both TestRegisteredJarVisibility and TestPigContextImportList pass. Thanks Rohini for the fix!

          cheolsoo Cheolsoo Park added a comment -

          Committed to trunk/branch-0.11.

          Thanks Rohini!


            People

            • Assignee:
              rohini Rohini Palaniswamy
              Reporter:
              cheolsoo Cheolsoo Park
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development