Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.0
    • Labels:
      None

      Description

      As we continue to explore the needs for Java 7 support with OpenJPA, it's been determined that our current dependency on Derby 10.5.x is not sufficient. Derby 10.8.x is the required level in order to support Java 7. We should be able to upgrade this dependency just from a runtime perspective – even before we make other changes in support of Java 7.

      1. OPENJPA-2084.patch
        0.5 kB
        Jacob Nowosatka

        Issue Links

          Activity

          Albert Lee added a comment -

          Close issue in preparation for 2.2.0 release.

          Jacob Nowosatka added a comment -

          The changes to the "documentation and other scripts" were committed under OpenJPA-2085.

          Kevin Sutter added a comment -

          Hi Jake, thanks for the patch. The update you proposed looks good from a purely dependency and testing perspective. But, what about the documentation and other scripts? At a minimum, we would like to update the documentation to show that we now support the 10.8.x version of Derby. And, some of the other testing and build scripts call out and reference specific versions of Derby. Do any of these need to be updated? I'd do a search on "derby" and "10.5" to see the type of references I am referring to. Let me know if additional updates are required for this patch. Thanks!

          Jacob Nowosatka added a comment -

          I updated the derby dependency to derby 10.8.2.2 and ran the tests. In all cases, there were no issues or regressions to speak of. I attached a patch with the fix, more or less for formality since the change is a very small one.


            People

            • Assignee:
              Jacob Nowosatka
              Reporter:
              Kevin Sutter
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development