Uploaded image for project: 'OpenJPA'
  1. OpenJPA
  2. OPENJPA-1520

Move trunk (2.0.x) to require Java 6 to build (but target 1.5 runtime)

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-beta
    • Fix Version/s: 2.0.0-beta2
    • Component/s: build / infrastructure
    • Labels:
      None
    • Patch Info:
      Patch Available

      Description

      http://n2.nabble.com/DISCUSS-Drop-build-support-for-Java-5-td2539470.html#a2540533

      We've had the discussion about dropping Java 5 support (build and runtime) from trunk. The above referenced string of notes indicates a favorable response. Before we do an official 2.0.0 release, we should make this change.

      Besides the build aspects, I believe we still have some Java 5 runtime implications in our runtime as well – some reflection processing due to the jdbc4 support. We should clean that up as well.

      I've talked to Donald about this and he's game to start this process, but please contribute ideas and testing as you see fit. Thanks.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                drwoods Donald Woods
                Reporter:
                kwsutter Kevin Sutter
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: