OpenJPA
  1. OpenJPA
  2. OPENJPA-1328

Move cacheable class configuration to ClassMetaData

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0, 1.2.1
    • Fix Version/s: 1.0.4, 1.2.2, 1.3.0, 2.0.0-beta
    • Component/s: datacache
    • Labels:
      None

      Description

      I'm proposing to move the cacheable class configuration processing from the datacache classes to ClassMetaData. The feature, introduced in OPENJPA-1045, effectively works by returning null for ClassMetaData.getDataCacheName(), where classes which should not be cached return null, otherwise the name of the datacache they may be cached by is returned.

      THe problem is that some third party datacache plugins are not reentrant, and the existing ClassMetaData.isCacheable() makes use of the method call getRepository().getConfiguration().getDataCacheManagerInstance(). This invokes the initialization of the datacache, which may result in further initialization/copying of CMD objects, which reenter the isCacheable() method. If a third party datacache plugin is not reentrant safe, this can cause a failure in the form of Exceptions or hung threads.

        Activity

        Jody Grassel added a comment -

        Proposed fix, patch for the 1.2.x stream

        Pinaki Poddar added a comment -

        ClassMetaData is not the right place for holding cache information, imo.
        Firstly, for practical use cases, caches are hardly partitioned by types.
        Secondly, the cache eligibility logic may be more user configurable than assigning all instances of a type statically to a single named cache.

        DataCacheManager seems to be much better abstraction to implement cache assignment to instances (even if only based on types).
        These changes are incorporated in trunk for OPENJPA-1334.


          People

          • Assignee:
            Michael Dick
            Reporter:
            Jody Grassel
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development