Details
-
Bug
-
Status: Resolved
-
Major
-
Resolution: Fixed
-
3.0.0-alpha1, 3.0.0-beta1, 3.0.0-alpha2
Description
The new erasure coding project has updated the protocol for fsimage such that the INodeFile has a boolean 'isStriped'. I think this is better as an enum or integer since a boolean precludes any future block types.
For example:
enum BlockType {
CONTIGUOUS = 0,
STRIPED = 1,
}
We can also make this more robust to future changes where there are different block types supported in a staged rollout. Here, we would use UNKNOWN_BLOCK_TYPE as the first value since this is the default value. See here for more discussion.
enum BlockType {
UNKNOWN_BLOCK_TYPE = 0,
CONTIGUOUS = 1,
STRIPED = 2,
}
But I'm not convinced this is necessary since there are other enums that don't use this approach.
Attachments
Attachments
Issue Links
- causes
-
HDFS-13287 TestINodeFile#testGetBlockType results in NPE when run alone
- Reopened
- is related to
-
HDFS-11465 Rename BlockType#CONTIGUOUS to BlockType#REPLICATED
- Resolved