HDFS-10759 introduced the a BlockType enum to INodeFile, with possible values CONTIGUOUS or STRIPED.
Since HDFS-8030 wants to implement "contiguous EC", CONTIGUOUS isn't an appropriate name. I propose we rename CONTIGUOUS to REPLICATED for clarity.
Change fsimage bool isStriped from boolean to an enum
Persist Erasure Coding Policy ID in a new optional field in INodeFile in FSImage