The new erasure coding project has updated the protocol for fsimage such that the INodeFile has a boolean 'isStriped'. I think this is better as an enum or integer since a boolean precludes any future block types.
We can also make this more robust to future changes where there are different block types supported in a staged rollout. Here, we would use UNKNOWN_BLOCK_TYPE as the first value since this is the default value. See here for more discussion.
But I'm not convinced this is necessary since there are other enums that don't use this approach.