Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-14814

Fix incompatible API change on FsServerDefaults to HADOOP-14104

Log workAgile BoardRank to TopRank to BottomAttach filesAttach ScreenshotBulk Copy AttachmentsBulk Move AttachmentsVotersWatch issueWatchersCreate sub-taskConvert to sub-taskMoveLinkCloneLabelsUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Blocker
    • Resolution: Fixed
    • None
    • 2.9.0, 3.0.0-beta1, 2.8.2
    • None
    • None

    Description

      From recently jdiff report: https://builds.apache.org/job/Hadoop-2.8-JACC/376/artifact/target/compat-check/report.html. We found an incompatible API change: in HADOOP-14104, we remove the constructor with replacing with more parameters. This will cause API incompatible given FsServerDefaults marked as public.
      We should fix it before 2.8.2 and 3.0-beta kicked out.

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            junping_du Junping Du Assign to me
            junping_du Junping Du
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment