Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-14814

Fix incompatible API change on FsServerDefaults to HADOOP-14104

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0, 3.0.0-beta1, 2.8.2
    • Component/s: None
    • Labels:
      None

      Description

      From recently jdiff report: https://builds.apache.org/job/Hadoop-2.8-JACC/376/artifact/target/compat-check/report.html. We found an incompatible API change: in HADOOP-14104, we remove the constructor with replacing with more parameters. This will cause API incompatible given FsServerDefaults marked as public.
      We should fix it before 2.8.2 and 3.0-beta kicked out.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                djp Junping Du
                Reporter:
                djp Junping Du
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: