Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.8.1.2
    • Fix Version/s: 10.8.1.2
    • Component/s: SQL
    • Labels:
      None

      Description

      Implement SYSCS_UTIL.UPDATE_STATISTICS by having the ALTER TABLE code use the new istat daemon in explicit mode.
      Doing this will allow for a period of limited exposure before the background mode of the daemon is enabled, and it will verify that the code generating the index statistics is working.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open In Progress In Progress
          9m 35s 1 Kristian Waagan 07/Dec/10 21:20
          In Progress In Progress Resolved Resolved
          26d 14h 51m 1 Kristian Waagan 03/Jan/11 12:11
          Resolved Resolved Closed Closed
          53d 8h 55m 1 Kristian Waagan 25/Feb/11 21:07
          Gavin made changes -
          Workflow jira [ 12539563 ] Default workflow, editable Closed status [ 12800999 ]
          Rick Hillegas made changes -
          Affects Version/s 10.8.1.2 [ 12316362 ]
          Affects Version/s 10.8.1.1 [ 12316356 ]
          Fix Version/s 10.8.1.2 [ 12316362 ]
          Fix Version/s 10.8.1.1 [ 12316356 ]
          Rick Hillegas made changes -
          Affects Version/s 10.8.1.1 [ 12316356 ]
          Affects Version/s 10.8.1.0 [ 12315561 ]
          Fix Version/s 10.8.1.1 [ 12316356 ]
          Fix Version/s 10.8.1.0 [ 12315561 ]
          Kristian Waagan made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Kristian Waagan added a comment -

          Closing issue.

          Kristian Waagan made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Fix Version/s 10.8.0.0 [ 12315561 ]
          Resolution Fixed [ 1 ]
          Kristian Waagan added a comment -

          Committed to trunk with revision 1054588.

          Any new test failures in tests running UPDATE_STATISTICS is likely to have been caused by this commit.

          Kristian Waagan made changes -
          Kristian Waagan added a comment -

          Attaching patch 1b (formatting change only).

          If you apply this patch now, calls to SYS_CS.UPDATE_STATISTICS will use the new daemon code committed in DERBY-4936.

          Kristian Waagan added a comment -

          This patch is blocked by, or dependent on, DERBY-4936.

          Kristian Waagan made changes -
          Link This issue is blocked by DERBY-4936 [ DERBY-4936 ]
          Kristian Waagan made changes -
          Kristian Waagan added a comment -

          Attached patch 1a, which makes SYS_CS.UPDATE_STATISTICS, and thus also ALTER TABLE, use the explicit mode daemon code to generate new statistics.

          Kristian Waagan made changes -
          Field Original Value New Value
          Status Open [ 1 ] In Progress [ 3 ]
          Kristian Waagan created issue -

            People

            • Assignee:
              Kristian Waagan
              Reporter:
              Kristian Waagan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development