Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-1198 Refactorings and Cleanups
  3. ZOOKEEPER-1257

Rename MultiTransactionRecord to MultiRequest

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Open
    • Priority: Critical
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Understanding the code behind multi operations doesn't get any easier when the code violates naming consistency.
      All other Request classes are called xxxRequest, only for multi its xxxTransactionRecord! Also "Transaction" is wrong, because there is the concepts of transactions that are transmitted between quorum peers or committed to disc. MultiTransactionRecord however is a Request from a client.

        Attachments

          Activity

            People

            • Assignee:
              thkoch Thomas Koch
              Reporter:
              thkoch Thomas Koch
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: