Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-6564

RM service is shutting down when ATS v2 is enabled

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: resourcemanager
    • Labels:
      None

      Description

      RM shutting down with following error

      2017-05-05 14:41:06,056 FATAL org.apache.hadoop.yarn.event.AsyncDispatcher: Error in dispatcher thread
      java.lang.IllegalAccessError: tried to access method com.google.common.base.Stopwatch.<init>()V from class org.apache.hadoop.hbase.zookeeper.MetaTableLocator
              at org.apache.hadoop.hbase.zookeeper.MetaTableLocator.blockUntilAvailable(MetaTableLocator.java:604)
              at org.apache.hadoop.hbase.zookeeper.MetaTableLocator.blockUntilAvailable(MetaTableLocator.java:588)
              at org.apache.hadoop.hbase.zookeeper.MetaTableLocator.blockUntilAvailable(MetaTableLocator.java:561)
      

        Issue Links

          Activity

          rohithsharma Rohith Sharma K S added a comment -

          Thanks Akhil PB for creating a JIRA.

          This looks like because of guava jar compatible version for hbase-client is different than hadoop guava dependencies. Hadoop guava version is 21.0 but hbase uses 12.01.
          I think we should use hbase-shaded-client jar? cc : / Vrushali C Joep Rottinghuis

          rohithsharma Rohith Sharma K S added a comment -

          I tried using hbase-shaded-client jar but RM start up itself failing with following error. Though guice jar is present in classpath, hbase shaded client jar is trying to load guava dependencies from shaded jar only. This appears like building hbase shaded client jar has issue. I am not sure somebody had tried using shaded since HBASE-13889.

          Error: A JNI error has occurred, please check your installation and try again
          Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/hadoop/hbase/shaded/com/google/inject/servlet/ServletModule
          	at java.lang.ClassLoader.defineClass1(Native Method)
          	at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
                  .......
          Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.hbase.shaded.com.google.inject.servlet.ServletModule
          	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
          	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
          	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
          	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
          
          vrushalic Vrushali C added a comment -

          Thanks Rohith and Akhil, we will have to look into this.

          vrushalic Vrushali C added a comment -

          Related jira which makes guava version configurable HADOOP-14380

          vrushalic Vrushali C added a comment -

          Trunk is being rolled back to guava 11
          HADOOP-14386

          sunilg Sunil G added a comment -

          Yes. I tested locally with HADOOP-14386 patch. It looks fine.

          rohithsharma Rohith Sharma K S added a comment -

          Thanks Sunil for testing with HADOOP-14386 patch. We shall keep this JIRA open until HADOOP-14386 fixed.

          haibochen Haibo Chen added a comment -

          Rohith Sharma K S Now that HADOOP-14386 has been resolved, what is the correct move here?

          vrushalic Vrushali C added a comment -

          I think this jira can be closed as "Not a problem"?

          rohithsharma Rohith Sharma K S added a comment -

          Yep, will close it.


            People

            • Assignee:
              rohithsharma Rohith Sharma K S
              Reporter:
              akhilpb Akhil PB
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development