Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-4654

Yarn node label CLI should parse "=" correctly when trying to remove all labels on a node

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 2.8.0, 3.0.0-alpha1
    • None
    • None
    • Reviewed

    Description

      Currently, when adding labels to nodes, user can run:
      yarn rmadmin -replaceLabelsOnNode "host1=x host2=y"

      However, when removing labels from a node, user has to run:
      yarn rmadmin -replaceLabelsOnNode "host1 host2"
      Instead of:
      yarn rmadmin -replaceLabelsOnNode "host1= host2="

      We should handle both of "=" exists/not-exists case when removing labels on a node.

      Attachments

        1. YARN-4654.v1.003.patch
          5 kB
          Naganarasimha G R
        2. YARN-4654.v1.002.patch
          4 kB
          Naganarasimha G R
        3. YARN-4654.v1.001.patch
          4 kB
          Naganarasimha G R

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Naganarasimha Naganarasimha G R
            leftnoteasy Wangda Tan
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment