Uploaded image for project: 'Hadoop YARN'
  1. Hadoop YARN
  2. YARN-4654

Yarn node label CLI should parse "=" correctly when trying to remove all labels on a node

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Currently, when adding labels to nodes, user can run:
      yarn rmadmin -replaceLabelsOnNode "host1=x host2=y"

      However, when removing labels from a node, user has to run:
      yarn rmadmin -replaceLabelsOnNode "host1 host2"
      Instead of:
      yarn rmadmin -replaceLabelsOnNode "host1= host2="

      We should handle both of "=" exists/not-exists case when removing labels on a node.

      1. YARN-4654.v1.001.patch
        4 kB
        Naganarasimha G R
      2. YARN-4654.v1.002.patch
        4 kB
        Naganarasimha G R
      3. YARN-4654.v1.003.patch
        5 kB
        Naganarasimha G R

        Activity

        Naganarasimha Naganarasimha G R added a comment -

        Hi Tan, Wangda,
        I took up this jira, hope you have not already started working on this ! If so please feel free to reassign.

        leftnoteasy Wangda Tan added a comment -

        Naganarasimha G R,
        Thanks! Please go ahead.

        Naganarasimha Naganarasimha G R added a comment -

        Hi Tan, Wangda,
        Have uploaded a patch to fix this issue, please review

        bibinchundatt Bibin A Chundatt added a comment -

        Naganarasimha G R
        Thanks for the patch looks good.
        Could you check the whitespace error

        ../patch/YARN-4654.v1.001.patch:63: trailing whitespace.
        
        warning: 1 line adds whitespace errors.
        
        Naganarasimha Naganarasimha G R added a comment -

        Thanks Bibin A Chundatt for the comments,
        Corrected the same in this patch !

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 0s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 53s trunk passed
        +1 compile 0m 16s trunk passed with JDK v1.8.0_66
        +1 compile 0m 18s trunk passed with JDK v1.7.0_91
        +1 checkstyle 0m 15s trunk passed
        +1 mvnsite 0m 23s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 0m 33s trunk passed
        +1 javadoc 0m 14s trunk passed with JDK v1.8.0_66
        +1 javadoc 0m 17s trunk passed with JDK v1.7.0_91
        +1 mvninstall 0m 19s the patch passed
        +1 compile 0m 12s the patch passed with JDK v1.8.0_66
        +1 javac 0m 12s the patch passed
        +1 compile 0m 15s the patch passed with JDK v1.7.0_91
        +1 javac 0m 15s the patch passed
        +1 checkstyle 0m 12s the patch passed
        +1 mvnsite 0m 21s the patch passed
        +1 mvneclipse 0m 10s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 0m 43s the patch passed
        +1 javadoc 0m 12s the patch passed with JDK v1.8.0_66
        +1 javadoc 0m 14s the patch passed with JDK v1.7.0_91
        -1 unit 64m 29s hadoop-yarn-client in the patch failed with JDK v1.8.0_66.
        -1 unit 64m 41s hadoop-yarn-client in the patch failed with JDK v1.7.0_91.
        +1 asflicense 0m 18s Patch does not generate ASF License warnings.
        142m 32s



        Reason Tests
        JDK v1.8.0_66 Failed junit tests hadoop.yarn.client.TestGetGroups
        JDK v1.8.0_66 Timed out junit tests org.apache.hadoop.yarn.client.cli.TestYarnCLI
          org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
          org.apache.hadoop.yarn.client.api.impl.TestYarnClient
          org.apache.hadoop.yarn.client.api.impl.TestNMClient
        JDK v1.7.0_91 Failed junit tests hadoop.yarn.client.TestGetGroups
        JDK v1.7.0_91 Timed out junit tests org.apache.hadoop.yarn.client.cli.TestYarnCLI
          org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
          org.apache.hadoop.yarn.client.api.impl.TestYarnClient
          org.apache.hadoop.yarn.client.api.impl.TestNMClient



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:0ca8df7
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12785120/YARN-4654.v1.002.patch
        JIRA Issue YARN-4654
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 7a32c2d40851 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / a277bdc
        Default Java 1.7.0_91
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10432/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10432/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/10432/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-YARN-Build/10432/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_91.txt
        JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10432/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client
        Max memory used 76MB
        Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/10432/console

        This message was automatically generated.

        Naganarasimha Naganarasimha G R added a comment -

        Test case failures are either not related to the modifications in the patch and timed out ones are passing locally.
        Rohith Sharma K S can you take a look at this ?

        Naganarasimha Naganarasimha G R added a comment -

        Had an offline discussion with Rohith Sharma K S and he was of the opinion that test case should fail when the modifications in RMAdminCLI is not present which was not happening in the patch. IIUC issue was not actually throwing a exception but intended behavior was not happening hence modified the test code to differ the behavior of CommonNodeLabelsManager when invalid NodeId is sent.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 17s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 25s trunk passed
        +1 compile 0m 15s trunk passed with JDK v1.8.0_72
        +1 compile 0m 19s trunk passed with JDK v1.7.0_95
        +1 checkstyle 0m 14s trunk passed
        +1 mvnsite 0m 23s trunk passed
        +1 mvneclipse 0m 12s trunk passed
        +1 findbugs 0m 33s trunk passed
        +1 javadoc 0m 14s trunk passed with JDK v1.8.0_72
        +1 javadoc 0m 17s trunk passed with JDK v1.7.0_95
        +1 mvninstall 0m 18s the patch passed
        +1 compile 0m 12s the patch passed with JDK v1.8.0_72
        +1 javac 0m 12s the patch passed
        +1 compile 0m 16s the patch passed with JDK v1.7.0_95
        +1 javac 0m 16s the patch passed
        +1 checkstyle 0m 12s the patch passed
        +1 mvnsite 0m 20s the patch passed
        +1 mvneclipse 0m 11s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 0m 42s the patch passed
        +1 javadoc 0m 12s the patch passed with JDK v1.8.0_72
        +1 javadoc 0m 15s the patch passed with JDK v1.7.0_95
        -1 unit 64m 31s hadoop-yarn-client in the patch failed with JDK v1.8.0_72.
        -1 unit 64m 44s hadoop-yarn-client in the patch failed with JDK v1.7.0_95.
        +1 asflicense 0m 17s Patch does not generate ASF License warnings.
        142m 15s



        Reason Tests
        JDK v1.8.0_72 Failed junit tests hadoop.yarn.client.TestGetGroups
        JDK v1.8.0_72 Timed out junit tests org.apache.hadoop.yarn.client.cli.TestYarnCLI
          org.apache.hadoop.yarn.client.api.impl.TestYarnClient
          org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
          org.apache.hadoop.yarn.client.api.impl.TestNMClient
        JDK v1.7.0_95 Failed junit tests hadoop.yarn.client.TestGetGroups
        JDK v1.7.0_95 Timed out junit tests org.apache.hadoop.yarn.client.cli.TestYarnCLI
          org.apache.hadoop.yarn.client.api.impl.TestYarnClient
          org.apache.hadoop.yarn.client.api.impl.TestAMRMClient
          org.apache.hadoop.yarn.client.api.impl.TestNMClient



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:0ca8df7
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12787868/YARN-4654.v1.003.patch
        JIRA Issue YARN-4654
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux ab99aadbf668 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / dea90c9
        Default Java 1.7.0_95
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_72 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10567/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_72.txt
        unit https://builds.apache.org/job/PreCommit-YARN-Build/10567/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_95.txt
        unit test logs https://builds.apache.org/job/PreCommit-YARN-Build/10567/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.8.0_72.txt https://builds.apache.org/job/PreCommit-YARN-Build/10567/artifact/patchprocess/patch-unit-hadoop-yarn-project_hadoop-yarn_hadoop-yarn-client-jdk1.7.0_95.txt
        JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-YARN-Build/10567/testReport/
        modules C: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client U: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client
        Console output https://builds.apache.org/job/PreCommit-YARN-Build/10567/console
        Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        Naganarasimha Naganarasimha G R added a comment -

        YARN-4351 captures the test case failures for hadoop.yarn.client.TestGetGroups and other timed out testcases are also related to the build machine so i think the jenkins report is fine!, Rohith Sharma K S/Tan, Wangda, can one of you have a look at the latest patch ?

        rohithsharma Rohith Sharma K S added a comment -

        +1 for the latest patch. I will wait couple of days before committing it.

        Naganarasimha Naganarasimha G R added a comment -

        Tan, Wangda,
        Is the latest patch fine ?

        leftnoteasy Wangda Tan added a comment -

        Tried this patch locally, works well for me, +1, thanks Naganarasimha G R/Rohith Sharma K S.

        rohithsharma Rohith Sharma K S added a comment -

        committed to trunk/branch-2/branch-2.8.. thanks Naganarasimha G R for your contributions and thanks Wangda Tan for the review!!

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #9320 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9320/)
        YARN-4654. Yarn node label CLI should parse "=" correctly when trying to (rohithsharmaks: rev c1afac3a98a4889d30a6ec7574a364fcbb6bb5b0)

        • hadoop-yarn-project/CHANGES.txt
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/test/java/org/apache/hadoop/yarn/client/cli/TestRMAdminCLI.java
        • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-client/src/main/java/org/apache/hadoop/yarn/client/cli/RMAdminCLI.java
        Naganarasimha Naganarasimha G R added a comment -

        Thanks for the review and commit Rohith Sharma K S & Wangda Tan!


          People

          • Assignee:
            Naganarasimha Naganarasimha G R
            Reporter:
            leftnoteasy Wangda Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development