Uploaded image for project: 'Wookie'
  1. Wookie
  2. WOOKIE-241

Version problems with JQueryMobile feature

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.9.2
    • Component/s: Server
    • Labels:
      None
    • Environment:
      Any widget using the JQueryMobile feature

      Description

      As JQM and JQ are included via a Wookie feature it is not possible for the widget to determine the version of them being used. This will lead to deployment problems when a feature of a newer version is not available in the wookie server in use.

      This is not just hyperthetical as I just hit a problem with the JQM $.mobile.path.parseUrlfunction being available in trunk but not on a test server.

      I propose the feature use have specify a version (at least for JQM). If none is specified us the latest

      I'd prefer to directly include JQM from the widget source. As it is we now have a tighter dependency on the Wookie server version - if a new JQM is released all target Wookie servers must be updated if the widget is to use it.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                stevelee Steve Lee
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: