Uploaded image for project: 'UIMA'
  1. UIMA
  2. UIMA-4506

Unreproducible test failure on Jenkins

    Details

      Description

      Encountered a test failure during XMI deserialization that I was unable to reproduce. Failure occurred on Jenkins:

      Building remotely on jenkins-ubuntu-1404-4gb-2d0 (jenkins-cloud-4GB cloud-slave Ubuntu ubuntu) in workspace /jenkins/workspace/UIMA-uimaFIT
      Unpacking http://archive.apache.org/dist/maven/binaries/apache-maven-3.0.3-bin.zip to /jenkins/tools/hudson.tasks.Maven_MavenInstallation/Maven_3.0.3 on jenkins-ubuntu-1404-4gb-2d0
      
      org.apache.uima.fit.util.SimplePipelineTest.test1
      
      Failing for the past 1 build (Since Unstable#209 )
      Took 8 ms.
      add description
      Error Message
      
      No sofaFS with name myView found.
      Stacktrace
      
      org.apache.uima.cas.CASRuntimeException: No sofaFS with name myView found.
      	at org.apache.uima.cas.impl.CASImpl.getSofa(CASImpl.java:786)
      	at org.apache.uima.cas.impl.CASImpl.getView(CASImpl.java:2978)
      	at org.apache.uima.cas.impl.XmiCasDeserializer$XmiCasDeserializerHandler.<init>(XmiCasDeserializer.java:280)
      	at org.apache.uima.cas.impl.XmiCasDeserializer$XmiCasDeserializerHandler.<init>(XmiCasDeserializer.java:78)
      	at org.apache.uima.cas.impl.XmiCasDeserializer.getXmiCasHandler(XmiCasDeserializer.java:1931)
      	at org.apache.uima.cas.impl.XmiCasDeserializer.deserialize(XmiCasDeserializer.java:2058)
      	at org.apache.uima.cas.impl.XmiCasDeserializer.deserialize(XmiCasDeserializer.java:1977)
      	at org.apache.uima.fit.util.CasIOUtil.readXmi(CasIOUtil.java:79)
      	at org.apache.uima.fit.util.CasIOUtil.readCas(CasIOUtil.java:58)
      	at org.apache.uima.fit.util.CasIOUtil.readJCas(CasIOUtil.java:178)
      	at org.apache.uima.fit.util.SimplePipelineTest.test1(SimplePipelineTest.java:41)
      

      I haven't been able to reproduce the problem locally (tried with Java 7, Java 8, with and without the extra Maven profiles active during the Jenkins build, from Eclipse and from CLI, not necessarily all combinations).

      Rebuilding on Jenkins without any changes to the code also made the problem go away. Maybe there is/was a problem with the build slave...? Anyway, this is spooky.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                rec Richard Eckart de Castilho
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: