Uploaded image for project: 'Tika'
  1. Tika
  2. TIKA-2535

Use latest org.opengis:geoapi to avoid rejected/EOL'd jsr-275 dependency

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.16, 1.17
    • Fix Version/s: 1.18, 2.0.0
    • Component/s: parser
    • Labels:
      None
    • Environment:

      All

      Description

      Tika currently depends on the very old (June 2011) 3.0.0 version of org.opengis:geoapi
      which in turn unfortunately pulls in the rejected jsr-275 as a dependency (which is EOL).

      However the latest 3.0.1 version of org.opengis:geoapi released recently (Sept 2017) switches to depending on the active 1.0 version of javax.measure.unit-api which is an implementation of jsr-363 which was accepted and effectively replaced the rejected jsr-275.

      Therefore requesting that Tika move to the 3.0.1 version of org.opengis:geoapi

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              tallison Tim Allison
              Reporter:
              Richard Jones Richard Jones

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment