Uploaded image for project: 'Apache NiFi'
  1. Apache NiFi
  2. NIFI-4806

Upgrade to Tika/Tika-Parsers 1.19 to resolve TIKA-2535 and CVEs reported against all releases prior to 1.19

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.5.0
    • Fix Version/s: 1.8.0
    • Component/s: Extensions
    • Labels:
      None

      Description

      The nifi-media-processors depend on Tika-Parsers 1.16 as of now.  They need to be upgraded to at least Tika-Parsers 1.18 to resolve the licensing problem identified to the Tika team and which they resolved in https://issues.apache.org/jira/browse/TIKA-2535

       

      We aren't susceptible to the licensing problem at this time because when we did the last update for Tika-Parsers this was flagged and excluded though we could be exposing bugs for certain datayptes we'd do mime detection on (maybe).  I have a comment about this in our pom.

       

      This Jira is to upgrade, ensure no invalid libs are used, and clean up the comments and move on.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mcgilman Matt Gilman
                Reporter:
                joewitt Joe Witt
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: