Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-2145

Rack and Thin are not just development dependencies

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.1
    • Fix Version/s: 0.9.2
    • Component/s: Ruby - Library
    • Labels:
      None
    • Environment:

      Mac OS X and Linux, Ruby v1.9.3

    • Patch Info:
      Patch Available

      Description

      The rack and thin gems should be specified as full dependencies, not just development dependencies.

      This is causing runtime errors when requiring thrift.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jfarrell Jake Farrell
                Reporter:
                keithbarrette Keith Barrette
              • Votes:
                6 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: