Uploaded image for project: 'Apache Storm'
  1. Apache Storm
  2. STORM-2558

The Windows command line storm.cmd script is outdated and doesn't work

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.0
    • Component/s: storm-core
    • Labels:
      None

      Description

      The storm.cmd script is very outdated, and isn't capable of starting Storm at this point. It also hasn't kept pace with the bash script. It should be replaced.

      I've ported the current bash script to powershell, but I'm wondering if we could put most of the current functionality into the python script, and just have the OS-specific scripts check the python version, then hand off to the python script.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                srdo Stig Rohde Døssing
                Reporter:
                srdo Stig Rohde Døssing
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 2.5h
                  2.5h