Uploaded image for project: 'Sentry'
  1. Sentry
  2. SENTRY-1893

Bump the minimum java version to 8

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.0.0
    • Component/s: None
    • Labels:
      None

      Description

      The latest version of Solr (6.x) requires Java 8. Also it looks like Oracle has already EOLed Java 7. It may be a good idea to bump the minimum JDK version for Sentry to Java 8 as well.

      Need to do as part of this version bump is:
      "When you switch to Java 8 you also need to update the version of error-prone to the latest one because it comes with Java7 compiler."

        Attachments

        1. SENTRY-1983.5.patch
          2 kB
          Sergio Peña
        2. SENTRY-1893-001.patch
          10 kB
          Hrishikesh Gadre
        3. SENTRY-1893.4.patch
          1 kB
          Sergio Peña
        4. SENTRY-1893.3.patch
          6 kB
          Sergio Peña
        5. SENTRY-1893.2.patch
          2 kB
          Sergio Peña

          Issue Links

            Activity

              People

              • Assignee:
                spena Sergio Peña
                Reporter:
                hgadre Hrishikesh Gadre
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: