Uploaded image for project: 'PDFBox'
  1. PDFBox
  2. PDFBOX-962

All sort of Problems when importing Xfdf files into PDFs -> damaged pdfs and NPEs


    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.8.11, 2.0.0
    • Component/s: Utilities
    • Labels:
    • Environment:
      kubuntu 10.04.2 LTS, jvm 1.6.2


      When trying to merge PDFs with there corresponding XFDFs all sort of Problems occur.

      I created different pdfs with form fields and a "sendbutton". (The Sendbutton triggers a send-action to
      send the form data via POST-Request to a URL in the XFDF format).

      Merging that xfdf data with the pdf worked only for the simplest most minimal Example: 1 Text-Input + Send Button.
      In the other cases I experienced some of the following problems

      • Missing checkbox
      • NPE in importFDF (acroForm == null)
      • Miss-rendered send-button (not working any longer: either URL damaged or document no send-able with strange Adobe message)

      I tried doing the same with the evaluation Version of Aspose Pdf Kit for Java which worked fine in all of that cases.

      I could provide examples of pdfs and and corresponding xfdf that show that faulty behavior


        1. kbb-NPE.pdf.zip
          6 kB
          Konstantinos Kostarellis



            • Assignee:
              tilman Tilman Hausherr
              koko Konstantinos Kostarellis
            • Votes:
              0 Vote for this issue
              2 Start watching this issue


              • Created: