OpenJPA
  1. OpenJPA
  2. OPENJPA-853

Informix cursor not open problem if synchronizeMapping set true

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.1, 1.3.0, 2.0.0-M2
    • Component/s: jdbc
    • Labels:
      None

      Description

      Informix JDBC driver default resultSet Holdability is 2 (CLOSE_CURSORS_OVER_COMMIT), which causes SQLException :Cursor not open.
      <openjpa-1.2.1-SNAPSHOT-r422266:723087 nonfatal general error> org.apache.openjpa.persistence.PersistenceException: Cursor not open.
      at org.apache.openjpa.jdbc.sql.DBDictionary.narrow(DBDictionary.java:4232)
      at org.apache.openjpa.jdbc.sql.DBDictionary.newStoreException(DBDictionary.java:4197)
      at org.apache.openjpa.jdbc.sql.SQLExceptions.getStore(SQLExceptions.java:102)
      at org.apache.openjpa.jdbc.sql.SQLExceptions.getStore(SQLExceptions.java:88)
      at org.apache.openjpa.jdbc.sql.SQLExceptions.getStore(SQLExceptions.java:64)
      at org.apache.openjpa.jdbc.kernel.SelectResultObjectProvider.handleCheckedException(SelectResultObjectProvider.java:155)
      at org.apache.openjpa.lib.rop.EagerResultList.<init>(EagerResultList.java:40)
      at org.apache.openjpa.kernel.QueryImpl.toResult(QueryImpl.java:1228)
      at org.apache.openjpa.kernel.QueryImpl.execute(QueryImpl.java:990)
      at org.apache.openjpa.kernel.QueryImpl.execute(QueryImpl.java:805)
      at org.apache.openjpa.kernel.QueryImpl.execute(QueryImpl.java:775)
      at org.apache.openjpa.kernel.QueryImpl.execute(QueryImpl.java:771)
      at org.apache.openjpa.kernel.DelegatingQuery.execute(DelegatingQuery.java:517)
      at org.apache.openjpa.persistence.QueryImpl.execute(QueryImpl.java:254)
      at org.apache.openjpa.persistence.QueryImpl.getResultList(QueryImpl.java:293)
      at com.ibm.ws.query.utils.SetupQueryTestCase.setUpEmpDept(SetupQueryTestCase.java:1359)
      at com.ibm.ws.query.utils.SetupQueryTestCase.setUp(SetupQueryTestCase.java:436)
      at com.ibm.ws.query.tests.ano.JUBulkUpdateTest.setUp(JUBulkUpdateTest.java:42)
      Caused by: java.sql.SQLException: Cursor not open.
      at com.informix.util.IfxErrMsg.getSQLException(IfxErrMsg.java:348)
      at com.informix.jdbc.IfxSqli.addException(IfxSqli.java:3000)
      at com.informix.jdbc.IfxSqli.receiveError(IfxSqli.java:3310)
      at com.informix.jdbc.IfxSqli.dispatchMsg(IfxSqli.java:2263)
      at com.informix.jdbc.IfxSqli.receiveMessage(IfxSqli.java:2183)
      at com.informix.jdbc.IfxSqli.executeFetch(IfxSqli.java:1835)
      at com.informix.jdbc.IfxSqli.getaRow(IfxSqli.java:4015)
      at com.informix.jdbc.IfxResultSet.next(IfxResultSet.java:533)
      at org.apache.commons.dbcp.DelegatingResultSet.next(DelegatingResultSet.java:168)
      at org.apache.openjpa.lib.jdbc.DelegatingResultSet.next(DelegatingResultSet.java:106)
      at org.apache.openjpa.jdbc.sql.ResultSetResult.nextInternal(ResultSetResult.java:222)
      at org.apache.openjpa.jdbc.sql.SelectImpl$SelectResult.nextInternal(SelectImpl.java:2451)
      at org.apache.openjpa.jdbc.sql.AbstractResult.next(AbstractResult.java:173)
      at org.apache.openjpa.jdbc.kernel.SelectResultObjectProvider.next(SelectResultObjectProvider.java:99)
      at org.apache.openjpa.lib.rop.EagerResultList.<init>(EagerResultList.java:35)
      ... 21 more

        Issue Links

          Activity

          Milosz Tylenda added a comment -

          A similar problem with Firebird has been reported in OPENJPA-775.

          Catalina Wei added a comment -

          fix checked in under OpenJPA svn:
          trunk - r733204,
          1.3.x - r733205
          1.2.x - r733206


            People

            • Assignee:
              Catalina Wei
              Reporter:
              Catalina Wei
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development