OpenJPA
  1. OpenJPA
  2. OPENJPA-801

slices: basic query is failing on sort.. not sure why

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M1
    • Fix Version/s: 2.0.0-M1
    • Component/s: slice
    • Labels:
      None

      Description

      I get this exception when running with slices, but no exception when running without slices. Not sure why. Any ideas? Clues?

      It looks to be expecting a "Val" object, but gets a "PCPath" object.

      <openjpa-2.0.0-SNAPSHOT-r422266:722060M nonfatal user error> org.apache.openjpa.persistence.ArgumentException: Failed to execute query "select this from com.protrade.fandom.data.entities.CheerStatus this where this.teamId = :p0 order by this.createTime desc". Check the query syntax for correctness. See nested exception for details.
      at org.apache.openjpa.kernel.QueryImpl.execute(QueryImpl.java:857)
      at org.apache.openjpa.kernel.QueryImpl.execute(QueryImpl.java:779)
      at org.apache.openjpa.kernel.DelegatingQuery.execute(DelegatingQuery.java:525)
      at org.apache.openjpa.persistence.QueryImpl.execute(QueryImpl.java:257)
      at org.apache.openjpa.persistence.QueryImpl.getResultList(QueryImpl.java:429)
      at com.protrade.common.persistence.JPAUtil.execute(JPAUtil.java:192)
      at com.protrade.common.persistence.JPAUtil.execute(JPAUtil.java:166)
      at com.protrade.common.persistence.JPAUtil.executeList(JPAUtil.java:151)
      at com.protrade.common.persistence.JPADQuery.list(JPADQuery.java:24)
      at com.protrade.common.persistence.BaseRootDAOBase.runListQueryNCS(BaseRootDAOBase.java:266)
      at com.protrade.common.persistence.BaseDAOBase.runListQueryNCS(BaseDAOBase.java:116)
      at com.protrade.fandom.data.CheersDAO.getLatestCheerStatusByTeam(CheersDAO.java:61)
      at com.protrade.fanwars.base.components.cheer.CheerInbox.setupRender(CheerInbox.java:90)
      at com.protrade.fanwars.base.components.cheer.CheerInbox.setupRender(CheerInbox.java)
      at org.apache.tapestry5.internal.structure.ComponentPageElementImpl$13$1.run(ComponentPageElementImpl.java:490)
      at org.apache.tapestry5.internal.structure.ComponentPageElementImpl.invoke(ComponentPageElementImpl.java:912)
      at org.apache.tapestry5.internal.structure.ComponentPageElementImpl.access$200(ComponentPageElementImpl.java:50)
      at org.apache.tapestry5.internal.structure.ComponentPageElementImpl$13.render(ComponentPageElementImpl.java:494)
      at org.apache.tapestry5.internal.services.RenderQueueImpl.run(RenderQueueImpl.java:72)
      at org.apache.tapestry5.internal.services.PageRenderQueueImpl.render(PageRenderQueueImpl.java:121)
      at $PageRenderQueue_11df3c111bb.render($PageRenderQueue_11df3c111bb.java)
      at $PageRenderQueue_11df3c111b1.render($PageRenderQueue_11df3c111b1.java)
      at org.apache.tapestry5.services.TapestryModule$19.renderMarkup(TapestryModule.java:1208)
      at com.protrade.tapestry5.base.services.GoogleAdManagerServices$GoogleAdManagerMarkupRenderFilter.renderMarkup(GoogleAdManagerServices.java:84)
      at $MarkupRenderer_11df3c111bd.renderMarkup($MarkupRenderer_11df3c111bd.java)
      at com.protrade.tapestry5.base.services.BaseTapestryModule$4.renderMarkup(BaseTapestryModule.java:186)
      at $MarkupRenderer_11df3c111bd.renderMarkup($MarkupRenderer_11df3c111bd.java)
      at com.protrade.tapestry5.base.services.BaseTapestryModule$3.renderMarkup(BaseTapestryModule.java:176)
      at $MarkupRenderer_11df3c111bd.renderMarkup($MarkupRenderer_11df3c111bd.java)
      at com.protrade.facebook.base.services.UnifiedSocialFacebookBaseModule$1.renderMarkup(UnifiedSocialFacebookBaseModule.java:65)
      at $MarkupRenderer_11df3c111bd.renderMarkup($MarkupRenderer_11df3c111bd.java)
      at org.apache.tapestry5.services.TapestryModule$26.renderMarkup(TapestryModule.java:1529)
      at $MarkupRenderer_11df3c111bd.renderMarkup($MarkupRenderer_11df3c111bd.java)
      at com.protrade.tapestry5.base.services.BaseTapestryModule$2.renderMarkup(BaseTapestryModule.java:168)
      at $MarkupRenderer_11df3c111bd.renderMarkup($MarkupRenderer_11df3c111bd.java)
      at org.apache.tapestry5.services.TapestryModule$28.renderMarkup(TapestryModule.java:1566)
      at $MarkupRenderer_11df3c111bd.renderMarkup($MarkupRenderer_11df3c111bd.java)
      at org.apache.tapestry5.services.TapestryModule$27.renderMarkup(TapestryModule.java:1547)
      at $MarkupRenderer_11df3c111bd.renderMarkup($MarkupRenderer_11df3c111bd.java)
      at com.protrade.pageproxy.services.PageProxyModule$1.renderMarkup(PageProxyModule.java:74)
      at $MarkupRenderer_11df3c111bd.renderMarkup($MarkupRenderer_11df3c111bd.java)
      at com.protrade.tapestry5.base.services.BaseTapestryModule$1.renderMarkup(BaseTapestryModule.java:160)
      at $MarkupRenderer_11df3c111bd.renderMarkup($MarkupRenderer_11df3c111bd.java)
      at org.apache.tapestry5.services.TapestryModule$25.renderMarkup(TapestryModule.java:1509)
      at $MarkupRenderer_11df3c111bd.renderMarkup($MarkupRenderer_11df3c111bd.java)
      at $MarkupRenderer_11df3c111b9.renderMarkup($MarkupRenderer_11df3c111b9.java)
      at org.apache.tapestry5.internal.services.PageMarkupRendererImpl.renderPageMarkup(PageMarkupRendererImpl.java:64)
      at $PageMarkupRenderer_11df3c111b7.renderPageMarkup($PageMarkupRenderer_11df3c111b7.java)
      at org.apache.tapestry5.internal.services.PageResponseRendererImpl.renderPageResponse(PageResponseRendererImpl.java:57)
      at $PageResponseRenderer_11df3c1106c.renderPageResponse($PageResponseRenderer_11df3c1106c.java)
      at org.apache.tapestry5.internal.services.PageRenderRequestHandlerImpl.handle(PageRenderRequestHandlerImpl.java:59)
      at com.protrade.facebook.base.services.FacebookAuthFilterImpl.handle(FacebookAuthFilterImpl.java:51)
      at $PageRenderRequestHandler_11df3c1106d.handle($PageRenderRequestHandler_11df3c1106d.java)
      at org.apache.tapestry5.services.TapestryModule$33.handle(TapestryModule.java:1747)
      at $PageRenderRequestHandler_11df3c1106d.handle($PageRenderRequestHandler_11df3c1106d.java)
      at com.protrade.facebook.base.services.FbForceModeFilter.handle(FbForceModeFilter.java:75)
      at $PageRenderRequestHandler_11df3c1106d.handle($PageRenderRequestHandler_11df3c1106d.java)
      at com.protrade.tapestry5.base.services.RequestLogFilter.handle(RequestLogFilter.java:23)
      at $PageRenderRequestHandler_11df3c1106d.handle($PageRenderRequestHandler_11df3c1106d.java)
      at com.protrade.opensocial.base.services.OsForceTypeFilter.handle(OsForceTypeFilter.java:75)
      at $PageRenderRequestHandler_11df3c1106d.handle($PageRenderRequestHandler_11df3c1106d.java)
      at $PageRenderRequestHandler_11df3c1105e.handle($PageRenderRequestHandler_11df3c1105e.java)
      at org.apache.tapestry5.internal.services.PageRenderDispatcher.process(PageRenderDispatcher.java:92)
      at org.apache.tapestry5.internal.services.PageRenderDispatcher.dispatch(PageRenderDispatcher.java:71)
      at $Dispatcher_11df3c11065.dispatch($Dispatcher_11df3c11065.java)
      at $Dispatcher_11df3c11057.dispatch($Dispatcher_11df3c11057.java)
      at org.apache.tapestry5.services.TapestryModule$17.service(TapestryModule.java:1034)
      at org.apache.tapestry5.internal.services.LocalizationFilter.service(LocalizationFilter.java:42)
      at $RequestHandler_11df3c11058.service($RequestHandler_11df3c11058.java)
      at org.apache.tapestry5.internal.services.RequestErrorFilter.service(RequestErrorFilter.java:26)
      at $RequestHandler_11df3c11058.service($RequestHandler_11df3c11058.java)
      at org.apache.tapestry5.services.TapestryModule$3.service(TapestryModule.java:626)
      at $RequestHandler_11df3c11058.service($RequestHandler_11df3c11058.java)
      at org.apache.tapestry5.services.TapestryModule$2.service(TapestryModule.java:616)
      at $RequestHandler_11df3c11058.service($RequestHandler_11df3c11058.java)
      at org.apache.tapestry5.internal.services.StaticFilesFilter.service(StaticFilesFilter.java:85)
      at $RequestHandler_11df3c11058.service($RequestHandler_11df3c11058.java)
      at com.protrade.pageproxy.services.PageProxyServices$PageProxyRequestFilter.service(PageProxyServices.java:265)
      at $RequestHandler_11df3c11058.service($RequestHandler_11df3c11058.java)
      at org.apache.tapestry5.internal.services.CheckForUpdatesFilter$2.invoke(CheckForUpdatesFilter.java:93)
      at org.apache.tapestry5.internal.services.CheckForUpdatesFilter$2.invoke(CheckForUpdatesFilter.java:84)
      at org.apache.tapestry5.ioc.internal.util.ConcurrentBarrier.withRead(ConcurrentBarrier.java:83)
      at org.apache.tapestry5.internal.services.CheckForUpdatesFilter.service(CheckForUpdatesFilter.java:106)
      at $RequestHandler_11df3c11058.service($RequestHandler_11df3c11058.java)
      at $RequestHandler_11df3c1104f.service($RequestHandler_11df3c1104f.java)
      at org.apache.tapestry5.services.TapestryModule$16.service(TapestryModule.java:1012)
      at org.apache.tapestry5.upload.internal.services.MultipartServletRequestFilter.service(MultipartServletRequestFilter.java:44)
      at $HttpServletRequestHandler_11df3c11050.service($HttpServletRequestHandler_11df3c11050.java)
      at org.apache.tapestry5.internal.services.IgnoredPathsFilter.service(IgnoredPathsFilter.java:62)
      at $HttpServletRequestFilter_11df3c1104e.service($HttpServletRequestFilter_11df3c1104e.java)
      at $HttpServletRequestHandler_11df3c11050.service($HttpServletRequestHandler_11df3c11050.java)
      at com.protrade.pageproxy.services.PageProxyServices$PageProxyHttpServletRequestFilter.service(PageProxyServices.java:202)
      at $HttpServletRequestHandler_11df3c11050.service($HttpServletRequestHandler_11df3c11050.java)
      at $HttpServletRequestHandler_11df3c1104c.service($HttpServletRequestHandler_11df3c1104c.java)
      at org.apache.tapestry5.TapestryFilter.doFilter(TapestryFilter.java:179)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
      at com.protrade.unifiedsocial.filters.NoUserSplashPageFilter.doFilter(NoUserSplashPageFilter.java:54)
      at com.protrade.common.web.ProtradeFilter.doFilter(ProtradeFilter.java:50)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
      at com.protrade.unifiedsocial.filters.USSPFilter.doFilter(USSPFilter.java:34)
      at com.protrade.common.web.ProtradeFilter.doFilter(ProtradeFilter.java:50)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
      at com.protrade.common.web.PCachedSessionStoreFilter.doFilter(PCachedSessionStoreFilter.java:39)
      at com.protrade.common.web.ProtradeFilter.doFilter(ProtradeFilter.java:50)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
      at com.protrade.pageproxy.filter.PageProxyAssetFilter.doFilter(PageProxyAssetFilter.java:53)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
      at com.protrade.fanwars.base.filters.FandomContextFilter.doFilter(FandomContextFilter.java:56)
      at com.protrade.common.web.ProtradeFilter.doFilter(ProtradeFilter.java:50)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
      at com.protrade.common.spring.OpenDSFilter$1.run(OpenDSFilter.java:43)
      at com.protrade.common.spring.OpenEMFilter$BindThreadRunnable.run(OpenEMFilter.java:129)
      at com.protrade.common.spring.OpenEMFilter$BindThreadRunnable.run(OpenEMFilter.java:129)
      at com.protrade.common.spring.OpenDSFilter.doFilter(OpenDSFilter.java:54)
      at com.protrade.common.web.ProtradeFilter.doFilter(ProtradeFilter.java:50)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
      at com.protrade.common.web.P3PFilter.doFilter(P3PFilter.java:15)
      at com.protrade.common.web.ProtradeFilter.doFilter(ProtradeFilter.java:50)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
      at com.protrade.common.web.CharsetFilter.doFilter(CharsetFilter.java:34)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:361)
      at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
      at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:417)
      at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
      at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
      at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
      at org.mortbay.jetty.Server.handle(Server.java:324)
      at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:534)
      at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:879)
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:741)
      at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:213)
      at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:403)
      at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:409)
      at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:522)
      Caused by: java.lang.ClassCastException: org.apache.openjpa.jdbc.kernel.exps.PCPath
      at org.apache.openjpa.kernel.ExpressionStoreQuery$DataStoreExecutor.getOrderingValue(ExpressionStoreQuery.java:734)
      at org.apache.openjpa.kernel.OrderingMergedResultObjectProvider.getOrderingValue(OrderingMergedResultObjectProvider.java:62)
      at org.apache.openjpa.lib.rop.MergedResultObjectProvider.next(MergedResultObjectProvider.java:172)
      at org.apache.openjpa.lib.rop.RangeResultObjectProvider.next(RangeResultObjectProvider.java:102)
      at org.apache.openjpa.lib.rop.EagerResultList.<init>(EagerResultList.java:35)
      at org.apache.openjpa.kernel.QueryImpl.toResult(QueryImpl.java:1233)
      at org.apache.openjpa.kernel.QueryImpl.execute(QueryImpl.java:995)
      at org.apache.openjpa.kernel.QueryImpl.execute(QueryImpl.java:848)
      ... 136 more

        Activity

        Fernando Padilla added a comment -

        Let me do a cleaner write up:

        It's complaining about the ordering value for some reason. The code that fails is copied below. It is trying to acquire the "ordering value" used in the query. It looks like it's expecting a "Val" object that it calls "evaluate" on to get the actual ordering value. But in Slices, it gets a "PCPath" object. Not sure how this is happening, but I guess that this method should just be fixed to work with either "Val" or "Path" objects. I would propose a patch, but I don't know how to evaluate a Path to get the value it points to..

        ExpressionStoreQuery$DataStoreExecutor.getOrderingValue :
        ......
        // use the parsed ordering expression to extract the ordering value
        Val val = (Val) _inMemOrdering[orderIndex];
        return val.evaluate(resultObject, resultObject,
        q.getContext().getStoreContext(), params);
        }
        ....

        Fernando Padilla added a comment -

        This is confusing me.

        I'm reviewing the code, and it looks like _inMemOrdering is a copy of QueryExpressions.ordering. Then I searched the whole code base for who modified QueryExpressions.ordering and I only found one place: JPQLQueryExpressionBuilder.evalOrderingClauses (code below). But that's weird because it looks like this method will ALWAYS fill the "odering" field with PCPath objects. But reviewing the rest of the code, it looks like everyone expects a "Val" object. So I'm not sure who coverts and replaces these "PCPath" objects with "Val" objects.

        Please, any clues??

        Fernando Padilla added a comment -

        So I reviewed the code again, and for some reason I must have been blind before, but it looks like PCPath does indeed implement the "Val" interface. So you should be able to cast "PCPath" to a "Val".

        So sadly, this might be some sort of class loading issue.. and I'm not sure how this could come about. The openjpa libraries are included only by my WEB-INF/lib, so there should only be one classloader involved right? I am running with Jetty, but that should not be an issue.

        Is OpenJPA doing something funky with class loaders and Plugins??

        Fernando Padilla added a comment -

        I am still at a loss, any help would be appreciated; here are more queries that are failing.. all for the same root exception

        select this from com.protrade.fandom.data.entities.fanwire.ArticleLink this where this.team = :p0 AND this.active = :p1 AND this.createTime > :p2 order by this.numBumps desc, this.createTime desc

        select this from com.protrade.fandom.data.entities.fanwire.ArticleLinkComment this where this.articleLink = :p0 AND this.active = :p1 order by this.createTime asc

        .....
        .....
        Caused by: java.lang.ClassCastException: org.apache.openjpa.jdbc.kernel.exps.PCPath
        at org.apache.openjpa.kernel.ExpressionStoreQuery$DataStoreExecutor.getOrderingValue(ExpressionStoreQuery.java:734)
        at org.apache.openjpa.kernel.OrderingMergedResultObjectProvider.getOrderingValue(OrderingMergedResultObjectProvider.java:62)
        at org.apache.openjpa.lib.rop.MergedResultObjectProvider.next(MergedResultObjectProvider.java:172)
        at org.apache.openjpa.lib.rop.RangeResultObjectProvider.next(RangeResultObjectProvider.java:102)
        at org.apache.openjpa.lib.rop.EagerResultList.<init>(EagerResultList.java:35)
        at org.apache.openjpa.kernel.QueryImpl.toResult(QueryImpl.java:1233)
        at org.apache.openjpa.kernel.QueryImpl.execute(QueryImpl.java:995)
        at org.apache.openjpa.kernel.QueryImpl.execute(QueryImpl.java:848)
        ... 136 more
        .....
        .....

        Pinaki Poddar added a comment -

        I have committed a change 724856 – which makes PCPath a CandidatePath.
        This is a departure from the common practice of other JDBC expressions not inheriting from equivalent kernel expressions.
        I am assuming that there must be a strong reason behind this decision of not extending kernel expressions.
        However, as the test corpus did not complain of the change and extraction of ordering value from an instance is non-trivial code in CandiddatePath, I have committed the change, but with some reservation.

        Will rollback on any objection to this change.

        More importantly, will someone illuminate why JDBC expressions do not inherit kernel expressions?


          People

          • Assignee:
            Pinaki Poddar
            Reporter:
            Fernando Padilla
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development