OpenJPA
  1. OpenJPA
  2. OPENJPA-634

SQLException not reported from Batched statement

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.0
    • Component/s: jdbc
    • Labels:
      None

      Description

      Batched update resulted in SQLException was not propagated back to application.

        Activity

        Catalina Wei created issue -
        Catalina Wei added a comment -

        fix checked in under r666512

        Catalina Wei made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Albert Lee added a comment -

        The previous fixes did not completely correct the problem scenario.

        In AbstractUpdateManager.flush(), it keeps track of 2 exception collections, one as a local variable in flush() and the 2nd one maintained by the prepare statement manger. These 2 collections are combined into a single collection and returned by flush().

        This approach caused the return collection not maintaining the order of exceptions took place during the flush. Typically the first exception contains the relevant information about the cause of failure and it allows the application to examine the cause and perform appropriate recovery action.

        Albert Lee.

        Albert Lee made changes -
        Resolution Fixed [ 1 ]
        Assignee Albert Lee [ allee8285 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Albert Lee made changes -
        Fix Version/s 1.2.0 [ 12313102 ]
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Albert Lee made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        15d 17h 11m 1 Catalina Wei 26/Jun/08 19:48
        Resolved Resolved Reopened Reopened
        4d 20h 33m 1 Albert Lee 01/Jul/08 16:22
        Reopened Reopened Resolved Resolved
        21h 56m 1 Albert Lee 02/Jul/08 14:18
        Resolved Resolved Closed Closed
        90d 2h 6m 1 Albert Lee 30/Sep/08 16:25

          People

          • Assignee:
            Albert Lee
            Reporter:
            Catalina Wei
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development