OpenJPA
  1. OpenJPA
  2. OPENJPA-632

setFirstResult and setMaxResults not working for Oracle.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.1, 1.0.2
    • Fix Version/s: 1.0.3
    • Component/s: None
    • Labels:
      None

      Description

      Marc caught this problem a few months ago and fixed it in trunk. I've discovered that the problem exists in 1.0.x as well and I'm porting the fix.

      I believe we already have sufficient test coverage - but we need to run the regression bucket more regularly on licensed databases (ie Oracle, DB2).

        Issue Links

          Activity

          Michael Dick created issue -
          Michael Dick added a comment -

          Reposting the comments Marc made when he committed rev 584463 for posterity :

          "The overridden toSelect() signature in the OracleDictionary was no longer appropriate since the DBDictionary.toSelect() change in revision #577972 (which fixed OPENJPA-378). This resulted in the special Oracle range handing to no longer take place, resulting in setFirstResult() and setMaxResults() effectively being ignored for Oracle."

          Michael Dick made changes -
          Field Original Value New Value
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Michael Dick [ mikedd ]
          Resolution Fixed [ 1 ]
          Julien Kronegg made changes -
          Link This issue is related to OPENJPA-759 [ OPENJPA-759 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          3m 46s 1 Michael Dick 10/Jun/08 22:33

            People

            • Assignee:
              Michael Dick
              Reporter:
              Michael Dick
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development