OpenJPA
  1. OpenJPA
  2. OPENJPA-6

OpenJPA doesn't meaningfully implement JDBC3, JDBC4 methods in its delegates

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1.0
    • Component/s: jdbc
    • Labels:
      None

      Description

      OpenJPA's JDBC wrappers throw UnsupportedOperationException for all the JDBC3 and JDBC4 methods. While OpenJPA doesn't use any of these methods, our mechanism for implementing them is limiting, in that users who obtain Connections from OpenJPA will not be able to use the new JDBC3/JDBC4 methods in their own code. Ideally, we should provide some means for people to designate to OpenJPA that it should use a dynamic proxy to implement the unimplemented methods. This shouldn't be the default behavior, as the dynamic proxy will add overhead, but certainly could be desirable for some. I'll file an issue.

        Issue Links

          Activity

          Patrick Linskey added a comment -

          Patrick also thought that 'Clone' would provide an opportunity to mutate the description.

          See the last paragraph of the description for the interesting bits.

          Patrick Linskey added a comment -

          This issue should also be low-priority, but I do not seem to have rights to (or knowledge of how to) change priorities.

          Patrick Linskey added a comment -

          Changed priority and description.

          Michael Dick added a comment -

          Closing issue which has been resolved for some time. If you believe the issue is not resolved please reopen or open a new issue.


            People

            • Assignee:
              Milosz Tylenda
              Reporter:
              Patrick Linskey
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development