OpenJPA
  1. OpenJPA
  2. OPENJPA-572

Merge operation fails with IdClass composite key

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0.2
    • Fix Version/s: 1.0.4, 1.2.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Description

      I've tried to use composite keys through the IdClass annotation, but the merge operation fails with the following error. I used the ApplicationIdTool to generate the IdClass object. What's odd is that I can take that exact same code and just switch the logic to use the Embeddable/EmbeddedId annotations and the merge command works.

      Exception in thread "main" <openjpa-1.0.2-r420667:627158 nonfatal user error> org.apache.openjpa.persistence.ArgumentException: The given value "idclass.CvssVector-1.0::Base" cannot be converted into an identity for "class idclass.CvssVector". The value is the wrong type (org.apache.openjpa.util.ObjectId).
      at org.apache.openjpa.kernel.BrokerImpl.newObjectId(BrokerImpl.java:1094)
      at org.apache.openjpa.kernel.VersionAttachStrategy.findFromDatabase(VersionAttachStrategy.java:372)
      at org.apache.openjpa.kernel.VersionAttachStrategy.attach(VersionAttachStrategy.java:77)
      at org.apache.openjpa.kernel.AttachManager.attach(AttachManager.java:241)
      at org.apache.openjpa.kernel.AttachManager.attach(AttachManager.java:101)
      at org.apache.openjpa.kernel.BrokerImpl.attach(BrokerImpl.java:3160)
      at org.apache.openjpa.kernel.DelegatingBroker.attach(DelegatingBroker.java:1142)
      at org.apache.openjpa.persistence.EntityManagerImpl.merge(EntityManagerImpl.java:665)
      at idclass.TestSave.main(TestSave.java:41)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.intellij.rt.execution.application.AppMain.main(AppMain.java:90)
      Caused by: java.lang.ClassCastException: org.apache.openjpa.util.ObjectId
      at idclass.CvssVector.pcCopyKeyFieldsToObjectId(CvssVector.java)
      at org.apache.openjpa.enhance.PCRegistry.copyKeyFieldsToObjectId(PCRegistry.java:160)
      at org.apache.openjpa.util.ApplicationIds.fromPKValues(ApplicationIds.java:195)
      at org.apache.openjpa.kernel.BrokerImpl.newObjectId(BrokerImpl.java:1087)
      ... 13 more

      1. test.zip
        4.24 MB
        Chadwick M Baatz

        Activity

        Chadwick M Baatz created issue -
        Chadwick M Baatz added a comment -

        Contains example code that causes failure. TestSave under embedded package works, TestSave under idclass package fails.

        Chadwick M Baatz made changes -
        Field Original Value New Value
        Attachment test.zip [ 12380330 ]
        Patrick Linskey made changes -
        Fix Version/s 1.0.2 [ 12312846 ]
        Fix Version/s 1.0.3 [ 12312969 ]
        Patrick Linskey added a comment -

        Moving to 1.0.3

        Fay Wang added a comment -

        Hi, This problem could be reproduced in openjpa 1.2 before Patrick checked in VersionAttachStrategy (r666896) for JIRA-245. As you said, the merge for IdClass failed, but works for embedded class. After Patrick's fix, the merge for IdClass works fine, but embedded id class now failed for merge. I did some investigation, and found that in your test case, you have both generatedValue annotation and EmbeddedId annotation, which makes openjpa think the detached object is a new entity. If I commented out the GeneratedValue annotation, your test case works fine when merging the entity with embedded id. .

        @Entity
        @Table(name = "cvss_vector")
        public class CvssVector
        implements Serializable
        {
        @GeneratedValue(strategy = GenerationType.IDENTITY)
        @Column(name = "cvss_vector_id", nullable = false, unique = true, updatable = false)
        private Long id = null;

        @EmbeddedId
        private CvssVectorId emId = null;

        Michael Dick added a comment -

        Defer to next release.

        Michael Dick made changes -
        Fix Version/s 1.0.3 [ 12312969 ]
        Fix Version/s 1.2.0 [ 12313102 ]
        Fix Version/s 1.0.4 [ 12313301 ]
        Pinaki Poddar made changes -
        Assignee Pinaki Poddar [ ppoddar@apache.org ]
        Pinaki Poddar made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Donald Woods made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        100d 26m 1 Pinaki Poddar 25/Jul/08 21:45
        Resolved Resolved Closed Closed
        591d 21h 46m 1 Donald Woods 09/Mar/10 18:32

          People

          • Assignee:
            Pinaki Poddar
            Reporter:
            Chadwick M Baatz
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development