OpenJPA
  1. OpenJPA
  2. OPENJPA-529

ManagedClassSubclasses stores table names twice.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: 1.0.3, 1.1.0
    • Component/s: None
    • Labels:
      None

      Description

      While tracking down a separate issue I noticed that the ManagedClassSubclasser was creating the same column name twice in a DynamicSchemaTable object. This problem was exposed while working on OPENJPA-528, the fix for that issue broke many of the unenhanced entity tests, due to this problem.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        1d 23h 18m 1 Michael Dick 02/Mar/08 21:29
        Closed Closed Reopened Reopened
        17d 21h 18m 1 Kevin Sutter 20/Mar/08 18:48
        Reopened Reopened Closed Closed
        19h 52m 1 Michael Dick 21/Mar/08 14:40
        Michael Dick made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Invalid [ 6 ]
        Michael Dick added a comment -

        I'm unable to reproduce the problem at the moment so I'm closing the issue.

        Kevin Sutter made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Kevin Sutter added a comment -

        Found a problem with this code fix. The clone() operation on the Configuration does not seem to be sufficient for the RuntimeEnhancement processing that happens later in this code path. I will revert this code change, but leave the Issue open for some other potential fix (if it's still required).

        Michael Dick made changes -
        Field Original Value New Value
        Resolution Fixed [ 1 ]
        Fix Version/s 1.1.0 [ 12312344 ]
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 1.0.3 [ 12312969 ]
        Michael Dick created issue -

          People

          • Assignee:
            Michael Dick
            Reporter:
            Michael Dick
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 20m
              20m
              Remaining:
              Remaining Estimate - 20m
              20m
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development