OpenJPA
  1. OpenJPA
  2. OPENJPA-504

Duplicate order numbers in relationshiptable for the same List field

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1.0, 1.2.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Kodo 4.1.4

      Description

      I now and then encounter entries in the relationship tables for List fields (id, element, ordr) non-unique entries for id, ordr. (Two elements are placed on the same index in the same list). I am not sure how to reproduce this, but I do have a question regarding the code in StoreCollectionFieldStrategy.load():

      ChangeTracker ct = null;
      if (field.getTypeCode() == JavaTypes.ARRAY)
      coll = new ArrayList();
      else

      { coll = sm.newProxy(field.getIndex()); if (coll instanceof Proxy) ct = ((Proxy) coll).getChangeTracker(); }

      // load values
      Result res = union.execute(store, fetch);
      try {
      int seq = 0;
      while (res.next())

      { if (ct != null && field.getOrderColumn() != null) seq = res.getInt(field.getOrderColumn()); add(store, coll, loadElement(sm, store, fetch, res, resJoins[res.indexOf()])); }

      if (ct != null && field.getOrderColumn() != null)
      ct.setNextSequence(seq + 1);
      } finally

      { res.close(); }

      If I am not mistaken, this initializes the changetracker for list fields for persistent objects loaded from the database with an empty list attribute (res.next() = false) with order number of "1", whereas objects with non-empty List fields which are persisted start with an order number of "0". Could this be the reason that I now and then encounter duplicate entries in the relationship table with ordernr "1"? Actually this is also the reason why encounter duplicates for other numbers, since order number is zero based (next sequence number is initialized to size()), but as described, some lists start counting from "1".

      kind regards,
      Christiaan

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        108d 20h 47m 1 Christiaan 13/May/08 13:48
        Resolved Resolved Closed Closed
        665d 5h 44m 1 Donald Woods 09/Mar/10 18:32
        Donald Woods made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Christiaan made changes -
        Resolution Fixed [ 1 ]
        Fix Version/s 1.1.0 [ 12312344 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 1.2.0 [ 12313102 ]
        Christiaan added a comment -

        Fixed due to issue OPENJPA-567

        Christiaan added a comment -

        The cause of the problem appears to be in different loading mechanisms. If the first time a collection is loaded using EAGER_NONE the sequence number is initialized to 1 instead of zero (see previous comment). When this is written to the datastore and loaded again the next time with EAGER_JOIN (resulting in StoreCollectionFieldStrategy.loadEagerJoin() which invokes CollectionChangeTrackerImpl.initialSequence()) the next sequence number will be initialized to the size of the collection => 1. So both element on index zero and one get the ordr value "1"

        Christiaan made changes -
        Field Original Value New Value
        Description I now and then encounter entries in the relationship tables for List fields (id, element, ordr) non-unique entries for id, ordr. (Two elements are placed on the same index in the same list). I am not sure how to reproduce this, but I do have a question regarding the code in StoreCollectionFieldStrategy.load():

        ChangeTracker ct = null;
                if (field.getTypeCode() == JavaTypes.ARRAY)
                    coll = new ArrayList();
                else {
                    coll = sm.newProxy(field.getIndex());
                    if (coll instanceof Proxy)
                        ct = ((Proxy) coll).getChangeTracker();
                }

                // load values
                Result res = union.execute(store, fetch);
                try {
                    int seq = 0;
                    while (res.next()) {
                        if (ct != null && field.getOrderColumn() != null)
                            seq = res.getInt(field.getOrderColumn());
                        add(store, coll, loadElement(sm, store, fetch, res,
                            resJoins[res.indexOf()]));
                    }
                    if (ct != null && field.getOrderColumn() != null)
                        ct.setNextSequence(seq + 1);
                } finally {
                    res.close();
                }

        If I am not mistaken, this initializes the changetracker for list fields for persistent objects loaded from the database with an empty list attribute (res.next() = false) with order number of "1", whereas objects with non-empty List fields which are persisted start with an order number of "0". Could this be the reason that I now and then encounter duplicate entries in the relationship table with ordernr "1"?

        kind regards,
        Christiaan
        I now and then encounter entries in the relationship tables for List fields (id, element, ordr) non-unique entries for id, ordr. (Two elements are placed on the same index in the same list). I am not sure how to reproduce this, but I do have a question regarding the code in StoreCollectionFieldStrategy.load():

        ChangeTracker ct = null;
                if (field.getTypeCode() == JavaTypes.ARRAY)
                    coll = new ArrayList();
                else {
                    coll = sm.newProxy(field.getIndex());
                    if (coll instanceof Proxy)
                        ct = ((Proxy) coll).getChangeTracker();
                }

                // load values
                Result res = union.execute(store, fetch);
                try {
                    int seq = 0;
                    while (res.next()) {
                        if (ct != null && field.getOrderColumn() != null)
                            seq = res.getInt(field.getOrderColumn());
                        add(store, coll, loadElement(sm, store, fetch, res,
                            resJoins[res.indexOf()]));
                    }
                    if (ct != null && field.getOrderColumn() != null)
                        ct.setNextSequence(seq + 1);
                } finally {
                    res.close();
                }

        If I am not mistaken, this initializes the changetracker for list fields for persistent objects loaded from the database with an empty list attribute (res.next() = false) with order number of "1", whereas objects with non-empty List fields which are persisted start with an order number of "0". Could this be the reason that I now and then encounter duplicate entries in the relationship table with ordernr "1"? Actually this is also the reason why encounter duplicates for other numbers, since order number is zero based (next sequence number is initialized to size()), but as described, some lists start counting from "1".

        kind regards,
        Christiaan
        Christiaan created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Christiaan
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development