Uploaded image for project: 'OpenJPA'
  1. OpenJPA
  2. OPENJPA-500

OpenJPAEntityManager.isManaged() is a confusing method name

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.0, 0.9.6, 0.9.7, 1.0.0, 1.0.1
    • Fix Version/s: 1.1.0
    • Component/s: jpa
    • Labels:
      None

      Description

      OpenJPAEntityManager.isManaged() is too close naming-wise to isTransient(Object), isDirty(Object), etc. We should deprecate this method and change the method name to something more self-documenting.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              pcl Patrick Linskey
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: