Uploaded image for project: 'OpenJPA'
  1. OpenJPA
  2. OPENJPA-404

Backward-compatibility for pre-1.0 APIs

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.1.0
    • Component/s: None
    • Labels:
      None

      Description

      When I changed the OpenJPA APIs before the 1.0 release, I made a number of incompatible changes. At the time, we deemed that this was fine since 1.0 was the first OpenJPA release. However, it turns out that this runs up against BEA policy, since BEA shipped a product using a build from around 0.9.7. So, we'd like to do some work to address this where possible.

        Attachments

        1. OPENJPA-404.patch
          34 kB
          Patrick Linskey

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                pcl Patrick Linskey
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: