Uploaded image for project: 'OpenJPA'
  1. OpenJPA
  2. OPENJPA-2821

Subclassing enhancer must use AsmAdapter

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.2
    • Fix Version/s: 3.1.3
    • Component/s: kernel
    • Labels:
      None

      Description

      Right now our subclassing factory only creates java 6 bytecode. We should update to use AsmAdapter to also create java8 bytecode.

        Attachments

          Activity

            People

            • Assignee:
              struberg Mark Struberg
              Reporter:
              struberg Mark Struberg
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: