Uploaded image for project: 'OpenJPA'
  1. OpenJPA
  2. OPENJPA-2616

Update Commons Collections to 3.2.2

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.1.0, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.4.0
    • Fix Version/s: 2.4.1
    • Component/s: jpa
    • Labels:
      None

      Description

      As documented by https://issues.apache.org/jira/browse/COLLECTIONS-580 Apache Commons Collections bears a significant exploit. This has been corrected in Apache Commons Collections 3.2.2 and OpenJPA should be updated from 3.2.1 to use this new level of Collections immediately.

        Attachments

          Activity

            People

            • Assignee:
              fyrewyld Jody Grassel
              Reporter:
              fyrewyld Jody Grassel
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: