OpenJPA
  1. OpenJPA
  2. OPENJPA-2097

GRAVE: Unable to inject field : [protected javax.persistence.EntityManager

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.1
    • Fix Version/s: None
    • Component/s: jpa
    • Labels:
    • Environment:
      Jetty 8 and Tomcat 7
      JPA 2.1.1
      CODI 1.0.3
      OpenWebBeans 1.1.3
      MyFaces Last

      Description

      GRAVE: Unable to inject field : [protected javax.persistence.EntityManager org.apache.webbeans.jsf2.TestDao.em]
      javax.persistence.PersistenceException: Explicit persistence provider error(s) occurred for "myDataBase" after trying the following discovered implementations: org.apache.openjpa.persistence.PersistenceProvi
      derImpl from provider: org.apache.openjpa.persistence.PersistenceProviderImpl
      at javax.persistence.Persistence.createPersistenceException(Persistence.java:244)
      at javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:186)
      at javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:72)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceProcessor.getPersistenceUnit(StandaloneResourceProcessor.java:140)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceProcessor.getPersistenceContext(StandaloneResourceProcessor.java:153)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceProcessor.getEntityManager(StandaloneResourceProcessor.java:69)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceInjectionService.getResourceReference(StandaloneResourceInjectionService.java:96)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceInjectionService.injectJavaEEResources(StandaloneResourceInjectionService.java:140)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectResources(AbstractInjectionTargetBean.java:432)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.createDefaultInstance(AbstractInjectionTargetBean.java:144)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.createInstance(AbstractInjectionTargetBean.java:114)
      at org.apache.webbeans.component.AbstractOwbBean.createNewInstance(AbstractOwbBean.java:234)
      at org.apache.webbeans.portable.creation.AbstractProducer.produce(AbstractProducer.java:79)
      at org.apache.webbeans.component.InjectionTargetWrapper.produce(InjectionTargetWrapper.java:139)
      at org.apache.webbeans.component.AbstractOwbBean.create(AbstractOwbBean.java:181)
      at org.apache.webbeans.context.DependentContext.getInstance(DependentContext.java:69)
      at org.apache.webbeans.context.AbstractContext.get(AbstractContext.java:190)
      at org.apache.webbeans.container.BeanManagerImpl.getReference(BeanManagerImpl.java:953)
      at org.apache.webbeans.container.BeanManagerImpl.getInjectableReference(BeanManagerImpl.java:834)
      at org.apache.webbeans.inject.AbstractInjectable.inject(AbstractInjectable.java:133)
      at org.apache.webbeans.inject.InjectableField.doInjection(InjectableField.java:59)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectField(AbstractInjectionTargetBean.java:384)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectFields(AbstractInjectionTargetBean.java:321)
      at org.apache.webbeans.portable.creation.InjectionTargetProducer.inject(InjectionTargetProducer.java:94)
      at org.apache.webbeans.component.InjectionTargetWrapper.inject(InjectionTargetWrapper.java:79)
      at org.apache.webbeans.component.AbstractOwbBean.create(AbstractOwbBean.java:182)
      at org.apache.webbeans.context.DependentContext.getInstance(DependentContext.java:69)
      at org.apache.webbeans.context.AbstractContext.get(AbstractContext.java:190)
      at org.apache.webbeans.container.BeanManagerImpl.getReference(BeanManagerImpl.java:953)
      at org.apache.webbeans.container.BeanManagerImpl.getInjectableReference(BeanManagerImpl.java:834)
      at org.apache.webbeans.inject.AbstractInjectable.inject(AbstractInjectable.java:133)
      at org.apache.webbeans.inject.InjectableField.doInjection(InjectableField.java:59)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectField(AbstractInjectionTargetBean.java:384)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectFields(AbstractInjectionTargetBean.java:321)
      at org.apache.webbeans.portable.creation.InjectionTargetProducer.inject(InjectionTargetProducer.java:94)
      at org.apache.webbeans.component.InjectionTargetWrapper.inject(InjectionTargetWrapper.java:79)
      at org.apache.webbeans.component.AbstractOwbBean.create(AbstractOwbBean.java:182)
      at org.apache.webbeans.context.creational.BeanInstanceBag.create(BeanInstanceBag.java:80)
      at org.apache.webbeans.context.AbstractContext.getInstance(AbstractContext.java:225)
      at org.apache.webbeans.context.AbstractContext.get(AbstractContext.java:190)
      at org.apache.webbeans.intercept.NormalScopedBeanInterceptorHandler.getContextualInstance(NormalScopedBeanInterceptorHandler.java:159)
      at org.apache.webbeans.intercept.NormalScopedBeanInterceptorHandler.invoke(NormalScopedBeanInterceptorHandler.java:119)
      at org.apache.webbeans.jsf2.TestBean_$$javassist_28.getComment(TestBean$$_javassist_28.java)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at javax.el.BeanELResolver.getValue(BeanELResolver.java:305)
      at javax.el.CompositeELResolver.getValue(CompositeELResolver.java:188)
      at org.apache.myfaces.el.unified.resolver.FacesCompositeELResolver.getValue(FacesCompositeELResolver.java:142)
      at com.sun.el.parser.AstValue.getValue(AstValue.java:120)
      at com.sun.el.parser.AstValue.getValue(AstValue.java:167)
      at com.sun.el.ValueExpressionImpl.getValue(ValueExpressionImpl.java:224)
      at org.apache.webbeans.el10.EL10ValueExpression.getValue(EL10ValueExpression.java:59)
      at org.apache.myfaces.view.facelets.el.TagValueExpression.getValue(TagValueExpression.java:85)
      at javax.faces.component._DeltaStateHelper.eval(_DeltaStateHelper.java:243)
      at javax.faces.component.UIOutput.getValue(UIOutput.java:71)
      at org.apache.myfaces.shared_impl.renderkit.RendererUtils.getValue(RendererUtils.java:343)
      at org.apache.myfaces.shared_impl.renderkit.RendererUtils.getStringValue(RendererUtils.java:295)
      at org.apache.myfaces.shared_impl.renderkit.html.HtmlTextRendererBase.renderOutput(HtmlTextRendererBase.java:92)
      at org.apache.myfaces.shared_impl.renderkit.html.HtmlTextRendererBase.encodeEnd(HtmlTextRendererBase.java:79)
      at javax.faces.component.UIComponentBase.encodeEnd(UIComponentBase.java:519)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:628)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:624)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:624)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:624)
      at org.apache.myfaces.view.facelets.FaceletViewDeclarationLanguage.renderView(FaceletViewDeclarationLanguage.java:1329)
      at org.apache.myfaces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:264)
      at javax.faces.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:59)
      at javax.faces.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:59)
      at org.apache.myfaces.lifecycle.RenderResponseExecutor.execute(RenderResponseExecutor.java:85)
      at org.apache.myfaces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:239)
      at org.apache.myfaces.extensions.cdi.jsf2.impl.listener.phase.CodiLifecycleWrapper.render(CodiLifecycleWrapper.java:126)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:191)
      at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:575)
      at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:488)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
      at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:483)
      at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:233)
      at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1061)
      at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:417)
      at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:192)
      at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:995)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
      at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:250)
      at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149)
      at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)
      at org.eclipse.jetty.server.Server.handle(Server.java:350)
      at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:431)
      at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:896)
      at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:647)
      at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:233)
      at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:68)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:609)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:45)
      at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:598)
      at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:533)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: <openjpa-2.1.1-r422266:1148538 fatal user error> org.apache.openjpa.persistence.ArgumentException: Could not invoke the static newInstance method on the named factory class "org.apache.openjpa.jdb
      c.kernel.JDBCBrokerFactory".
      at org.apache.openjpa.kernel.Bootstrap.newBrokerFactory(Bootstrap.java:76)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.getBrokerFactory(PersistenceProviderImpl.java:151)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.createEntityManagerFactory(PersistenceProviderImpl.java:95)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.createEntityManagerFactory(PersistenceProviderImpl.java:157)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.createEntityManagerFactory(PersistenceProviderImpl.java:66)
      at javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:152)
      ... 96 more
      Caused by: <openjpa-2.1.1-r422266:1148538 nonfatal user error> org.apache.openjpa.persistence.ArgumentException: This configuration disallows runtime optimization, but the following listed types were not enh
      anced at build time or at class load time with a javaagent: "
      org.apache.webbeans.jsf2.Test".
      at org.apache.openjpa.enhance.ManagedClassSubclasser.prepareUnenhancedClasses(ManagedClassSubclasser.java:116)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.loadPersistentTypes(AbstractBrokerFactory.java:315)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.initializeBroker(AbstractBrokerFactory.java:239)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.newBroker(AbstractBrokerFactory.java:213)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.newBroker(AbstractBrokerFactory.java:186)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.postCreationCallback(AbstractBrokerFactory.java:855)
      at org.apache.openjpa.jdbc.kernel.JDBCBrokerFactory.postCreationCallback(JDBCBrokerFactory.java:105)
      at org.apache.openjpa.kernel.Bootstrap.newBrokerFactory(Bootstrap.java:67)
      ... 101 more
      20-dic-2011 17:02:15 org.apache.webbeans.component.ManagedBean injectResources
      GRAVE: An error occured while injecting Java EE Resources for the bean instance : [org.apache.webbeans.jsf2.TestDao@1c94b51]
      20-dic-2011 17:02:15 org.apache.myfaces.view.facelets.FaceletViewDeclarationLanguage handleRenderException
      GRAVE: Error Rendering View[/test.xhtml]
      javax.faces.FacesException: Could not retrieve value of component with path :

      {Component-Path : [Class: javax.faces.component.UIViewRoot,ViewId: /test.xhtml][Class: javax.faces.component.html.HtmlBody,Id: j_ id2114509110_7e08d902][Class: javax.faces.component.html.HtmlForm,Id: form][Class: javax.faces.component.html.HtmlOutputText,Id: j_id2114509110_7e08d943]}

      at org.apache.myfaces.shared_impl.renderkit.RendererUtils.getValue(RendererUtils.java:347)
      at org.apache.myfaces.shared_impl.renderkit.RendererUtils.getStringValue(RendererUtils.java:295)
      at org.apache.myfaces.shared_impl.renderkit.html.HtmlTextRendererBase.renderOutput(HtmlTextRendererBase.java:92)
      at org.apache.myfaces.shared_impl.renderkit.html.HtmlTextRendererBase.encodeEnd(HtmlTextRendererBase.java:79)
      at javax.faces.component.UIComponentBase.encodeEnd(UIComponentBase.java:519)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:628)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:624)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:624)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:624)
      at org.apache.myfaces.view.facelets.FaceletViewDeclarationLanguage.renderView(FaceletViewDeclarationLanguage.java:1329)
      at org.apache.myfaces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:264)
      at javax.faces.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:59)
      at javax.faces.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:59)
      at org.apache.myfaces.lifecycle.RenderResponseExecutor.execute(RenderResponseExecutor.java:85)
      at org.apache.myfaces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:239)
      at org.apache.myfaces.extensions.cdi.jsf2.impl.listener.phase.CodiLifecycleWrapper.render(CodiLifecycleWrapper.java:126)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:191)
      at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:575)
      at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:488)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
      at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:483)
      at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:233)
      at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1061)
      at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:417)
      at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:192)
      at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:995)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
      at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:250)
      at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149)
      at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)
      at org.eclipse.jetty.server.Server.handle(Server.java:350)
      at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:431)
      at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:896)
      at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:647)
      at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:233)
      at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:68)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:609)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:45)
      at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:598)
      at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:533)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: javax.el.ELException: /test.xhtml at line 30 and column 47 value="#

      {testBean.comment}

      ": <openjpa-2.1.1-r422266:1148538 nonfatal user error> org.apache.openjpa.persistence.ArgumentException: This c
      onfiguration disallows runtime optimization, but the following listed types were not enhanced at build time or at class load time with a javaagent: "
      org.apache.webbeans.jsf2.Test".
      at org.apache.myfaces.view.facelets.el.TagValueExpression.getValue(TagValueExpression.java:93)
      at javax.faces.component._DeltaStateHelper.eval(_DeltaStateHelper.java:243)
      at javax.faces.component.UIOutput.getValue(UIOutput.java:71)
      at org.apache.myfaces.shared_impl.renderkit.RendererUtils.getValue(RendererUtils.java:343)
      ... 40 more
      Caused by: <openjpa-2.1.1-r422266:1148538 nonfatal user error> org.apache.openjpa.persistence.ArgumentException: This configuration disallows runtime optimization, but the following listed types were not enh
      anced at build time or at class load time with a javaagent: "
      org.apache.webbeans.jsf2.Test".
      at org.apache.openjpa.enhance.ManagedClassSubclasser.prepareUnenhancedClasses(ManagedClassSubclasser.java:116)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.loadPersistentTypes(AbstractBrokerFactory.java:315)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.initializeBroker(AbstractBrokerFactory.java:239)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.newBroker(AbstractBrokerFactory.java:213)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.newBroker(AbstractBrokerFactory.java:186)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.postCreationCallback(AbstractBrokerFactory.java:855)
      at org.apache.openjpa.jdbc.kernel.JDBCBrokerFactory.postCreationCallback(JDBCBrokerFactory.java:105)
      at org.apache.openjpa.kernel.Bootstrap.newBrokerFactory(Bootstrap.java:67)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.getBrokerFactory(PersistenceProviderImpl.java:151)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.createEntityManagerFactory(PersistenceProviderImpl.java:95)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.createEntityManagerFactory(PersistenceProviderImpl.java:157)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.createEntityManagerFactory(PersistenceProviderImpl.java:66)
      at javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:152)
      at javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:72)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceProcessor.getPersistenceUnit(StandaloneResourceProcessor.java:140)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceProcessor.getPersistenceContext(StandaloneResourceProcessor.java:153)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceProcessor.getEntityManager(StandaloneResourceProcessor.java:69)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceInjectionService.getResourceReference(StandaloneResourceInjectionService.java:96)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceInjectionService.injectJavaEEResources(StandaloneResourceInjectionService.java:140)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectResources(AbstractInjectionTargetBean.java:432)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.createDefaultInstance(AbstractInjectionTargetBean.java:144)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.createInstance(AbstractInjectionTargetBean.java:114)
      at org.apache.webbeans.component.AbstractOwbBean.createNewInstance(AbstractOwbBean.java:234)
      at org.apache.webbeans.portable.creation.AbstractProducer.produce(AbstractProducer.java:79)
      at org.apache.webbeans.component.InjectionTargetWrapper.produce(InjectionTargetWrapper.java:139)
      at org.apache.webbeans.component.AbstractOwbBean.create(AbstractOwbBean.java:181)
      at org.apache.webbeans.context.DependentContext.getInstance(DependentContext.java:69)
      at org.apache.webbeans.context.AbstractContext.get(AbstractContext.java:190)
      at org.apache.webbeans.container.BeanManagerImpl.getReference(BeanManagerImpl.java:953)
      at org.apache.webbeans.container.BeanManagerImpl.getInjectableReference(BeanManagerImpl.java:834)
      at org.apache.webbeans.inject.AbstractInjectable.inject(AbstractInjectable.java:133)
      at org.apache.webbeans.inject.InjectableField.doInjection(InjectableField.java:59)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectField(AbstractInjectionTargetBean.java:384)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectFields(AbstractInjectionTargetBean.java:321)
      at org.apache.webbeans.portable.creation.InjectionTargetProducer.inject(InjectionTargetProducer.java:94)
      at org.apache.webbeans.component.InjectionTargetWrapper.inject(InjectionTargetWrapper.java:79)
      at org.apache.webbeans.component.AbstractOwbBean.create(AbstractOwbBean.java:182)
      at org.apache.webbeans.context.DependentContext.getInstance(DependentContext.java:69)
      at org.apache.webbeans.context.AbstractContext.get(AbstractContext.java:190)
      at org.apache.webbeans.container.BeanManagerImpl.getReference(BeanManagerImpl.java:953)
      at org.apache.webbeans.container.BeanManagerImpl.getInjectableReference(BeanManagerImpl.java:834)
      at org.apache.webbeans.inject.AbstractInjectable.inject(AbstractInjectable.java:133)
      at org.apache.webbeans.inject.InjectableField.doInjection(InjectableField.java:59)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectField(AbstractInjectionTargetBean.java:384)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectFields(AbstractInjectionTargetBean.java:321)
      at org.apache.webbeans.portable.creation.InjectionTargetProducer.inject(InjectionTargetProducer.java:94)
      at org.apache.webbeans.component.InjectionTargetWrapper.inject(InjectionTargetWrapper.java:79)
      at org.apache.webbeans.component.AbstractOwbBean.create(AbstractOwbBean.java:182)
      at org.apache.webbeans.context.creational.BeanInstanceBag.create(BeanInstanceBag.java:80)
      at org.apache.webbeans.context.AbstractContext.getInstance(AbstractContext.java:225)
      at org.apache.webbeans.context.AbstractContext.get(AbstractContext.java:190)
      at org.apache.webbeans.intercept.NormalScopedBeanInterceptorHandler.getContextualInstance(NormalScopedBeanInterceptorHandler.java:159)
      at org.apache.webbeans.intercept.NormalScopedBeanInterceptorHandler.invoke(NormalScopedBeanInterceptorHandler.java:119)
      at org.apache.webbeans.jsf2.TestBean_$$javassist_28.getComment(TestBean$$_javassist_28.java)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at javax.el.BeanELResolver.getValue(BeanELResolver.java:305)
      at javax.el.CompositeELResolver.getValue(CompositeELResolver.java:188)
      at org.apache.myfaces.el.unified.resolver.FacesCompositeELResolver.getValue(FacesCompositeELResolver.java:142)
      at com.sun.el.parser.AstValue.getValue(AstValue.java:120)
      at com.sun.el.parser.AstValue.getValue(AstValue.java:167)
      at com.sun.el.ValueExpressionImpl.getValue(ValueExpressionImpl.java:224)
      at org.apache.webbeans.el10.EL10ValueExpression.getValue(EL10ValueExpression.java:59)
      at org.apache.myfaces.view.facelets.el.TagValueExpression.getValue(TagValueExpression.java:85)
      ... 43 more
      20-dic-2011 17:02:15 org.apache.myfaces.renderkit.ErrorPageWriter handleThrowable
      GRAVE: An exception occurred
      javax.faces.FacesException: <openjpa-2.1.1-r422266:1148538 nonfatal user error> org.apache.openjpa.persistence.ArgumentException: This configuration disallows runtime optimization, but the following listed t
      ypes were not enhanced at build time or at class load time with a javaagent: "
      org.apache.webbeans.jsf2.Test".
      at org.apache.myfaces.shared_impl.context.ExceptionHandlerImpl.wrap(ExceptionHandlerImpl.java:241)
      at org.apache.myfaces.shared_impl.context.ExceptionHandlerImpl.handle(ExceptionHandlerImpl.java:156)
      at org.apache.myfaces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:258)
      at org.apache.myfaces.extensions.cdi.jsf2.impl.listener.phase.CodiLifecycleWrapper.render(CodiLifecycleWrapper.java:126)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:191)
      at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:575)
      at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:488)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
      at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:483)
      at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:233)
      at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1061)
      at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:417)
      at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:192)
      at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:995)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
      at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:250)
      at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149)
      at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)
      at org.eclipse.jetty.server.Server.handle(Server.java:350)
      at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:431)
      at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:896)
      at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:647)
      at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:233)
      at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:68)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:609)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:45)
      at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:598)
      at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:533)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: <openjpa-2.1.1-r422266:1148538 nonfatal user error> org.apache.openjpa.persistence.ArgumentException: This configuration disallows runtime optimization, but the following listed types were not enh
      anced at build time or at class load time with a javaagent: "
      org.apache.webbeans.jsf2.Test".
      at org.apache.openjpa.enhance.ManagedClassSubclasser.prepareUnenhancedClasses(ManagedClassSubclasser.java:116)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.loadPersistentTypes(AbstractBrokerFactory.java:315)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.initializeBroker(AbstractBrokerFactory.java:239)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.newBroker(AbstractBrokerFactory.java:213)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.newBroker(AbstractBrokerFactory.java:186)
      at org.apache.openjpa.kernel.AbstractBrokerFactory.postCreationCallback(AbstractBrokerFactory.java:855)
      at org.apache.openjpa.jdbc.kernel.JDBCBrokerFactory.postCreationCallback(JDBCBrokerFactory.java:105)
      at org.apache.openjpa.kernel.Bootstrap.newBrokerFactory(Bootstrap.java:67)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.getBrokerFactory(PersistenceProviderImpl.java:151)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.createEntityManagerFactory(PersistenceProviderImpl.java:95)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.createEntityManagerFactory(PersistenceProviderImpl.java:157)
      at org.apache.openjpa.persistence.PersistenceProviderImpl.createEntityManagerFactory(PersistenceProviderImpl.java:66)
      at javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:152)
      at javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:72)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceProcessor.getPersistenceUnit(StandaloneResourceProcessor.java:140)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceProcessor.getPersistenceContext(StandaloneResourceProcessor.java:153)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceProcessor.getEntityManager(StandaloneResourceProcessor.java:69)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceInjectionService.getResourceReference(StandaloneResourceInjectionService.java:96)
      at org.apache.webbeans.resource.spi.se.StandaloneResourceInjectionService.injectJavaEEResources(StandaloneResourceInjectionService.java:140)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectResources(AbstractInjectionTargetBean.java:432)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.createDefaultInstance(AbstractInjectionTargetBean.java:144)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.createInstance(AbstractInjectionTargetBean.java:114)
      at org.apache.webbeans.component.AbstractOwbBean.createNewInstance(AbstractOwbBean.java:234)
      at org.apache.webbeans.portable.creation.AbstractProducer.produce(AbstractProducer.java:79)
      at org.apache.webbeans.component.InjectionTargetWrapper.produce(InjectionTargetWrapper.java:139)
      at org.apache.webbeans.component.AbstractOwbBean.create(AbstractOwbBean.java:181)
      at org.apache.webbeans.context.DependentContext.getInstance(DependentContext.java:69)
      at org.apache.webbeans.context.AbstractContext.get(AbstractContext.java:190)
      at org.apache.webbeans.container.BeanManagerImpl.getReference(BeanManagerImpl.java:953)
      at org.apache.webbeans.container.BeanManagerImpl.getInjectableReference(BeanManagerImpl.java:834)
      at org.apache.webbeans.inject.AbstractInjectable.inject(AbstractInjectable.java:133)
      at org.apache.webbeans.inject.InjectableField.doInjection(InjectableField.java:59)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectField(AbstractInjectionTargetBean.java:384)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectFields(AbstractInjectionTargetBean.java:321)
      at org.apache.webbeans.portable.creation.InjectionTargetProducer.inject(InjectionTargetProducer.java:94)
      at org.apache.webbeans.component.InjectionTargetWrapper.inject(InjectionTargetWrapper.java:79)
      at org.apache.webbeans.component.AbstractOwbBean.create(AbstractOwbBean.java:182)
      at org.apache.webbeans.context.DependentContext.getInstance(DependentContext.java:69)
      at org.apache.webbeans.context.AbstractContext.get(AbstractContext.java:190)
      at org.apache.webbeans.container.BeanManagerImpl.getReference(BeanManagerImpl.java:953)
      at org.apache.webbeans.container.BeanManagerImpl.getInjectableReference(BeanManagerImpl.java:834)
      at org.apache.webbeans.inject.AbstractInjectable.inject(AbstractInjectable.java:133)
      at org.apache.webbeans.inject.InjectableField.doInjection(InjectableField.java:59)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectField(AbstractInjectionTargetBean.java:384)
      at org.apache.webbeans.component.AbstractInjectionTargetBean.injectFields(AbstractInjectionTargetBean.java:321)
      at org.apache.webbeans.portable.creation.InjectionTargetProducer.inject(InjectionTargetProducer.java:94)
      at org.apache.webbeans.component.InjectionTargetWrapper.inject(InjectionTargetWrapper.java:79)
      at org.apache.webbeans.component.AbstractOwbBean.create(AbstractOwbBean.java:182)
      at org.apache.webbeans.context.creational.BeanInstanceBag.create(BeanInstanceBag.java:80)
      at org.apache.webbeans.context.AbstractContext.getInstance(AbstractContext.java:225)
      at org.apache.webbeans.context.AbstractContext.get(AbstractContext.java:190)
      at org.apache.webbeans.intercept.NormalScopedBeanInterceptorHandler.getContextualInstance(NormalScopedBeanInterceptorHandler.java:159)
      at org.apache.webbeans.intercept.NormalScopedBeanInterceptorHandler.invoke(NormalScopedBeanInterceptorHandler.java:119)
      at org.apache.webbeans.jsf2.TestBean_$$javassist_28.getComment(TestBean$$_javassist_28.java)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at javax.el.BeanELResolver.getValue(BeanELResolver.java:305)
      at javax.el.CompositeELResolver.getValue(CompositeELResolver.java:188)
      at org.apache.myfaces.el.unified.resolver.FacesCompositeELResolver.getValue(FacesCompositeELResolver.java:142)
      at com.sun.el.parser.AstValue.getValue(AstValue.java:120)
      at com.sun.el.parser.AstValue.getValue(AstValue.java:167)
      at com.sun.el.ValueExpressionImpl.getValue(ValueExpressionImpl.java:224)
      at org.apache.webbeans.el10.EL10ValueExpression.getValue(EL10ValueExpression.java:59)
      at org.apache.myfaces.view.facelets.el.TagValueExpression.getValue(TagValueExpression.java:85)
      at javax.faces.component._DeltaStateHelper.eval(_DeltaStateHelper.java:243)
      at javax.faces.component.UIOutput.getValue(UIOutput.java:71)
      at org.apache.myfaces.shared_impl.renderkit.RendererUtils.getValue(RendererUtils.java:343)
      at org.apache.myfaces.shared_impl.renderkit.RendererUtils.getStringValue(RendererUtils.java:295)
      at org.apache.myfaces.shared_impl.renderkit.html.HtmlTextRendererBase.renderOutput(HtmlTextRendererBase.java:92)
      at org.apache.myfaces.shared_impl.renderkit.html.HtmlTextRendererBase.encodeEnd(HtmlTextRendererBase.java:79)
      at javax.faces.component.UIComponentBase.encodeEnd(UIComponentBase.java:519)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:628)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:624)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:624)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:624)
      at org.apache.myfaces.view.facelets.FaceletViewDeclarationLanguage.renderView(FaceletViewDeclarationLanguage.java:1329)
      at org.apache.myfaces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:264)
      at javax.faces.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:59)
      at javax.faces.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:59)
      at org.apache.myfaces.lifecycle.RenderResponseExecutor.execute(RenderResponseExecutor.java:85)
      at org.apache.myfaces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:239)
      ... 26 more

      1. owb.rar
        27 kB
        Esteve

        Activity

        Rick Curtis added a comment -

        As the Exception states, you didn't enhance your Entities. Please review the following link[1] detailing how to run the enhancer.

        I'm closing this JIRA as there is no bug here. If you have additional questions, please utilize the users mailing list[2].

        [ but the following listed types were not enhanced at build time or at class load time with a javaagent: "org.apache.webbeans.jsf2.Test". ]

        [1] http://openjpa.apache.org/entity-enhancement.html
        [2] http://openjpa.apache.org/mailing-lists.html

        Esteve added a comment -

        Project example


          People

          • Assignee:
            Rick Curtis
            Reporter:
            Esteve
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development