Uploaded image for project: 'OpenJPA'
  1. OpenJPA
  2. OPENJPA-2070

Error processing while populating Metamodel classes needs improvement

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.0
    • Component/s: criteria
    • Labels:
      None

      Description

      The MetamodelImpl.populate() method needs some improvements in the error processing arena. This scenario is coming about due to the changes in OPENJPA-2027. If our current 2.2.x runtime implementation runs against a metamodel class that was generated prior to the fix in OPENJPA-2027, the exception produced does not show what the error was (and we're missing the "caused by" exception). These updates will help identify the root cause issue.

        Issue Links

          Activity

          allee8285 Albert Lee added a comment -

          Close issue in preparation for 2.2.0 release.

          jira-bot ASF subversion and git services added a comment -

          Commit 1469488 from hthomann
          [ https://svn.apache.org/r1469488 ]

          OPENJPA-2070: Error processing while populating Metamodel classes needs improvement. Back-ported to 2.1.x Kevin Sutter's trunk changes.


            People

            • Assignee:
              kwsutter Kevin Sutter
              Reporter:
              kwsutter Kevin Sutter
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development