OpenJPA
  1. OpenJPA
  2. OPENJPA-2036

DynamicEnhancer should look for tools.jar in java.home/lib for all JDKs, not just the IBM SDK.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.2.0
    • Component/s: Enhance
    • Labels:
    • Environment:
      XP 64bit Sun/Oracle JDK 64 bit 1.6.0_26
    • Patch Info:
      Patch Available

      Description

      FINE: java.home=C:\Program Files\Java\jdk1.6.0_26\jre
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels setUp
      FINE: javaHomeFile=C:\Program Files\Java\jdk1.6.0_26\jre
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels setUp
      FINE: toolsJarFile=C:\Program Files\Java\jdk1.6.0_26\jre\lib\tools.jar
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels setUp
      FINE: toolsJarFile.exists()=false
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels setUp
      FINE: absPath=C:\Program Files\Java\jdk1.6.0_26\jre
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels setUp
      FINE: sfx=\jre
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels setUp
      FINE: absPath.endsWith(File.separator + "jre")=true
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels setUp
      FINE: javaHomeFile=C:\Program Files\Java\jdk1.6.0_26
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels setUp
      FINE: toolsJarFile=C:\Program Files\Java\jdk1.6.0_26\lib\tools.jar
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels setUp
      FINE: toolsJarFile.exists()=true
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels$1 trace
      FINE: JPA:org.apache.openjpa.enhance.InstrumentationFactory.getInstrumentation() _inst:sun.instrument.InstrumentationImpl@d8d9850 _dynamicallyInstall:true
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels setUp
      FINE: initialiazing openJPA javaagent... sun.instrument.InstrumentationImpl@d8d9850
      Jul 27, 2011 5:21:15 PM com.carefirst.fep.local.commons.model.claim.TestClaimModels setUp
      FINE: factory created

      1. openjpa-enhancer-findtools-fix.jar
        11 kB
        Jason Pyeron
      2. OPENJPA-2036.diff.txt
        2 kB
        Michael Dick

        Issue Links

          Activity

          Jason Pyeron created issue -
          Jason Pyeron added a comment -

          sorry it is not in patch form, can patchify it on the weekend.

          Jason Pyeron made changes -
          Field Original Value New Value
          Attachment openjpa-enhancer-findtools-fix.jar [ 12488030 ]
          Jason Pyeron made changes -
          Link This issue is related to OPENJPA-952 [ OPENJPA-952 ]
          Michael Dick added a comment -

          I've taken the liberty of rewording the summary. Basically what the patch does is remove the check for the IBM JDK and unconditionally look for tools.jar in $

          {JAVA_HOME}

          /lib.

          Michael Dick made changes -
          Summary change since OPENJPA-952 has resulted in a regression, the assumption that only IBM JDK behaves in a given way was false DynamicEnhancer should look for tools.jar in java.home/lib for all JDKs, not just the IBM SDK.
          Michael Dick added a comment -

          Attaching patch based on the jar previously attached.

          Michael Dick made changes -
          Attachment OPENJPA-2036.diff.txt [ 12488108 ]
          Michael Dick made changes -
          Assignee Michael Dick [ mikedd ]
          Michael Dick added a comment -

          Thanks for the patch.

          This change will show up in the nightly snapshots for 2.2.0. Please give one of them a try and let us know if it worked.

          Michael Dick made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 2.2.0 [ 12315910 ]
          Resolution Fixed [ 1 ]
          Albert Lee added a comment -

          Close issue in preparation for 2.2.0 release.

          Albert Lee made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Michael Dick
              Reporter:
              Jason Pyeron
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development