OpenJPA
  1. OpenJPA
  2. OPENJPA-1861

Update maven plugins used in builds to support Maven 3.0

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.1.0
    • Component/s: build / infrastructure
    • Labels:
      None

      Description

      Apache Maven 3.0 has been released and we have some build failures when using it, like -
      openjpa-lib - multiple versions of Ant being used in the builds. Fix is to upgrade some old ant-1.6.5.jar usage to match the 1.7.1 used by the maven-antrun-plugin and set an exclusion on one dependency that is pulling in ant-1.5
      openjpa-all - shade plugin trying to jar up the target/classes directory when it shouldn't. Fix is to remove the maven-jar-plugin usage from the openjpa-all/pom.xml
      Also, will be upgrading all the other maven plugins to the latest levels, as some newer releases include Maven 3.0 fixes or additional settings. Will verify the builds still work with Maven 2.2.1 and 3.0.

        Activity

        Hide
        Michael Dick added a comment -

        Closing issue which has been resolved for some time. If you believe the issue is not resolved please reopen or open a new issue.

        Show
        Michael Dick added a comment - Closing issue which has been resolved for some time. If you believe the issue is not resolved please reopen or open a new issue.

          People

          • Assignee:
            Donald Woods
            Reporter:
            Donald Woods
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development