OpenJPA
  1. OpenJPA
  2. OPENJPA-1830

Deserialization of EMF causes connectionPassword to be overwritten with Value.INVISIBLE

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.1.0
    • Component/s: None
    • Labels:
      None
    • Patch Info:
      Patch Available

      Description

      ConfigurationImpl.writeExternal() serializes out the toProperties() and Map _props, which both contain the connectionPassword. When readExternal() deserializes, the StringValue of connectionPassword gets its value set twice, which causes Value.INVISIBLE to get set as the value, which never happens if the EMF is never serialized.

        Issue Links

          Activity

          Donald Woods added a comment -

          causing junit test failures due to new surefire setup, where we're setting openjpa.ConnectionPassword instead of passing it in openjpa.ConnectionProperties.

          Donald Woods added a comment -

          will no longer override string values with Value.INVISIBLE of "******".

          Michael Dick added a comment -

          Closing issue which has been resolved for some time. If you believe the issue is not resolved please reopen or open a new issue.


            People

            • Assignee:
              Donald Woods
              Reporter:
              Donald Woods
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development