Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.0.2, 2.1.0
    • Component/s: tooling
    • Labels:
      None
    • Environment:
      Win XP

      Description

      When I see the type="text" attribute in a Hibernate property element I would like to be able to convert that to a <lob/> child element in OpenJPA.

      For example, I would like the following line in a Hibernate hbm.xml file:

      <property name="value" column="VALUE" type="text"/>

      to become the following orm.xml entry:

      <basic name="value">
      <column name="VALUE"/>
      <lob/>
      </basic>

      I can get <lob/> by using this in the actions for "property" in migration-actions.xml:

      <promote-attr from="type" to="lob">
      <map-value from="text" to=""/>
      </promote-attr>

      but that will only work if type's value is "text". It would be great if we could introduce a new type in migration-actions.xsd: "ignore-value". We can already ignore elements and attributes, but not values yet (unless they have particular values like the example above). Then I could do something like this:

      <promote-attr from="type" to="lob">
      <ignore-value/>
      </promote-attr>

        Activity

        Michael Dick added a comment -

        Closing issue which has been resolved for some time. If you believe the issue is not resolved please reopen or open a new issue.

        Pinaki Poddar added a comment -

        Added new action syntax
        <promote-attr from="type" to="lob" if="text"/>

        Will convert
        <property name="value" column="COL_VALUE" type="text"/>
        to
        <basic name="value">
        <column name="COL_VALUE"/>
        <lob/>
        </basic>


          People

          • Assignee:
            Pinaki Poddar
            Reporter:
            Lucas Partridge
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development