OpenJPA
  1. OpenJPA
  2. OPENJPA-1809

Refresh of versioned entity locked with pessimistic locking throws incorrect exception

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0, 2.0.1, 2.1.0
    • Fix Version/s: 2.1.0
    • Component/s: None
    • Labels:
      None

      Description

      Attempting to call em.refresh(), using javax.persistence.lock.timeout value on a locked versioned entity results in a non-fatal OptimisticLockException. Instead, a non-fatal LockTimeoutException should be thrown by OpenJPA.

        Activity

        Michael Dick made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Michael Dick added a comment -

        Closing issue which has been resolved for some time. If you believe the issue is not resolved please reopen or open a new issue.

        Jeremy Bauer made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.1.0 [ 12314542 ]
        Resolution Fixed [ 1 ]
        Jeremy Bauer created issue -

          People

          • Assignee:
            Jeremy Bauer
            Reporter:
            Jeremy Bauer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development