OpenJPA
  1. OpenJPA
  2. OPENJPA-1667

Incorrect column type for LOB streaming in MySQL

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.3.0, 2.0.0
    • Fix Version/s: 1.3.0, 2.1.0
    • Component/s: sql
    • Labels:
      None
    • Environment:
      MySQL 5.1.30

      Description

      After the changes made in OPENJPA-740, a LOB streaming field is mapped to TINYBLOB instead of BLOB in MySQL. This is because column size is -1 and in MySQLDictionary.getColumnType we assume that only size = 0 means "size unknown". Adding a check for -1 will probably resolve the issue.

        Issue Links

          Activity

          Michael Dick added a comment -

          Closing issue which has been resolved for some time. If you believe the issue is not resolved please reopen or open a new issue.


            People

            • Assignee:
              Milosz Tylenda
              Reporter:
              Milosz Tylenda
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development