Uploaded image for project: 'OpenJPA'
  1. OpenJPA
  2. OPENJPA-1665

Problems when using auto incrementing colums that start at zero

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 1.2.3, 1.3.0, 2.0.2, 2.1.0
    • Component/s: None
    • Labels:
      None

      Description

      This issue was reported on the users mailing list[1].

      The issue is that it is possible when using auto generated ids that there is a current entity in the persistence context that has an id of zero, and by default when a new entity is created it also has an id of zero. When persisting the second entity, OpenJPA incorrectly detects that there are multiple entities with the same id in the context even though the new id doesn't have an id from the database yet.

      [1]http://openjpa.208410.n2.nabble.com/An-object-of-type-src-StatusUpdate-with-oid-0-already-exists-in-this-context-another-cannot-be-persi-td5030272.html#a5030272

        Issue Links

          Activity

          curtisr7 Rick Curtis added a comment -

          Committed revision 943638 to trunk.

          Updated BrokerImpl to skip checks for duplicate ids when they are auto generated. Also added a new test case to exercise this code path.

          milosz Milosz Tylenda added a comment -

          Changing Fix Version to 2.1.0 since code has been committed to trunk.

          mikedd Michael Dick added a comment -

          Closing issues which have been resolved for some time. If the problem persists, please reopen.

          jpaheath Heath Thomann added a comment -

          Committed changes to 2.0.x under revision 1084264.

          mikedd Michael Dick added a comment -

          Looks like the 2.0.2 changes were made under r1084264.


            People

            • Assignee:
              curtisr7 Rick Curtis
              Reporter:
              curtisr7 Rick Curtis
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development